Community

Forums » SEPHP Help and Tips

Internal Server Error after PHP Upgrade

    • 31 posts
    September 25, 2019 7:11 PM EDT

    We are currently using EasyApache4 with the default PHP version of 7.0. When we attempt to switch to 7.2 or 7.3 our website does not load and we receive the 500 Internal Server Error. We are currently running 4.10.3p4 and are attempting to upgrade to 4.10.5 which requires PHP7.2

    Any thoughts on how to resolve this would be appreciated.

    • 31 posts
    September 25, 2019 7:33 PM EDT

    This is the detailed error received. It appears to be due to Redis but we are unsure how to correct it.

     

    Fatal error: Uncaught Zend_Cache_Exception: The redis extension must be loaded for using this backend ! in /home/admin/public_html/application/libraries/Zend/Cache.php:209 Stack trace: #0 /home/admin/public_html/application/libraries/Engine/Cache/Backend/Redis.php(44): Zend_Cache::throwException('The redis exten...') #1 /home/admin/public_html/application/libraries/Zend/Cache.php(153): Engine_Cache_Backend_Redis->__construct(Array) #2 /home/admin/public_html/application/libraries/Zend/Cache.php(94): Zend_Cache::_makeBackend('Engine_Cache_Ba...', Array, true, false) #3 /home/admin/public_html/application/libraries/Engine/Cache.php(211): Zend_Cache::factory('core', 'Engine_Cache_Ba...', Array, Array, false, true, false) #4 /home/admin/public_html/application/modules/Core/Bootstrap.php(284): Engine_Cache::factory('core', 'Engine_Cache_Ba...', Array, Array, false, true) #5 /home/admin/public_html/application/libraries/Engine/Application/Bootstrap/Abstract.php(256): Core_Bootstrap->_initCache() #6 /home/admin/public_html/appli in /home/admin/public_html/application/libraries/Zend/Cache.php on line 209

    • 31 posts
    September 25, 2019 7:48 PM EDT

    Well in case someone else runs into the issue, I was able to resolve it. I did not enable the Redis PHP extension for PHP version 7.2 or 7.3. Once I did this, all was good.

    • Moderator
    • 3861 posts
    September 26, 2019 4:54 AM EDT

    Please note that php 7.3 is not supported yet. Thank you for posting your findings for the issues you had as I'm sure it'll help others.

    • 31 posts
    September 26, 2019 4:58 AM EDT
    Hello Donna.... Hope you have been well. I did run into other issues while on 7.2. random errors. I will be digging into it a bit more and will post the findings here.
    • Moderator
    • 3861 posts
    September 26, 2019 5:20 AM EDT

    If you find bugs with the SEPHP product please post those in separate bug reports for us if you can please. Or, one 7.2 issue report is ok but not ideal. :) Thank you! BTW, I've been using 7.2 on my own site for quite a while without anything showing but I don't use third party products yet on it. 

    • Moderator
    • 3861 posts
    September 26, 2019 5:20 AM EDT

    Oh and yes, I've been fine. Hope you are :)