Forums » SEPHP Help and Tips

SEPHP UPgrade Error

    • 53 posts
    September 30, 2019 10:39 AM EDT

    Hello

    I had SocialEngineAddOns perform my SEPHP upgrade and they report this error: "Zend_Db_Adapter_Mysqli_Exception: MySQL server has gone away"

    How do we resolve?

    Thanks Gary

    • Moderator
    • 3835 posts
    September 30, 2019 12:56 PM EDT

    Please ask your host to check the database. Normally that's a crash. https://dev.mysql.com/doc/refman/8.0/en/gone-away.html

    • 53 posts
    October 1, 2019 10:33 AM EDT

    Hi Donna

    Upgrade completed, FastComet host found:

    Hello again, Thank you for your patience up to now. After further investigation it occur that the database adapter in the configuration file is no set correct. In order to utilize PHP 7+ versions the MySQL adapter should be pdo_mysql. As soon as I have performed that change I am able to see your website loading properly.

    Thanks Gary

    • Moderator
    • 3835 posts
    October 1, 2019 1:01 PM EDT

    Glad you got it sorted out! Thank you for posting your solution too as it will help other clients that might have the same issue.

    • Moderator
    • 3835 posts
    October 4, 2019 5:52 AM EDT

    I was looking at this again and it appears that they are not updating the servers to the requirements. You shouldn't need or be using the pdo_mysql as you should be using MySQLi as our requirements show:

    https://www.socialengine.com/support/article/81788966/se-php-socialengine-requirements

    They might want to check all of the new requirements.