Community

Forums » SEPHP Help and Tips

Support mariadb

    • 21 posts
    October 6, 2019 1:38 AM EDT

    It is a huge turn off for me when knowing that with the recent release of SE does not support mariadb. My server is currently running mariadb and to transition to mysql might be a huge hassle. I would hope that SE would be compatible with both mysql and mariadb

    • 3747 posts
    October 6, 2019 5:11 AM EDT

    Please follow the stickied guidelines for posting a feature request if you would like it considered. Thank you.

    • 190 posts
    October 8, 2019 12:57 PM EDT

    I use mariadb and it works fine 

    • 21 posts
    October 8, 2019 1:12 PM EDT

    Which version of se are you using. Cause with version se 4.10.5 you need to have mysql

    • 190 posts
    October 8, 2019 1:23 PM EDT

    I had the latest on it, i'll install again now 

    • 21 posts
    October 8, 2019 1:29 PM EDT
    I tried to upgrade from se 4.10.4 to the latest and was interrupted by mysql 5.7 requirement therefore couldn't complete the upgrade. But I have mariadb 5.5 I wonder if it has anything to do with it as I can see you have mariadb 10.3
    • 21 posts
    October 8, 2019 1:30 PM EDT
    Actually correction I do have mariadb 10.3
    • 190 posts
    October 8, 2019 1:39 PM EDT

     

     

    works fine for me, 

    • 21 posts
    October 10, 2019 1:17 AM EDT

     

    Not sure what's the difference

    • 190 posts
    October 10, 2019 5:26 AM EDT
    Your MySQL version is 5.0 that’s what’s wrong.
    • 3747 posts
    October 10, 2019 6:05 AM EDT

    Yes, please see our requirements before upgrading. 

    • 21 posts
    October 15, 2019 9:20 PM EDT
    PeppaPigKilla said:
    Your MySQL version is 5.0 that’s what’s wrong.

    What you see is MYSQL client 5.0 which is completely different from MYSQL server.

     

    Would you mind showing me the screenshot of the "Webserver Section" from your phpmyadmin?

    • 7 posts
    November 1, 2019 3:43 PM EDT

    Hi,

    we have the same error with

    • Server-Typ: MariaDB
    • Server-Version: 10.1.39-MariaDB-1~stretch -

    and we can't update to SE 4.10.5

    • module-core-4.10.5 : MySQL 5.7
    • Requires at least version 5.7
    • Please solve the above problems before proceeding

    Thanks & Regards

    Dieter

    • 21 posts
    November 2, 2019 1:58 PM EDT
    I was able to upgrade sussessfully to SE 4.10.5 with a little tweak for mariadb server. This however, will not work in the long run as mariadb and mysql might have two separate routes
    • 7 posts
    November 3, 2019 10:41 AM EST

    Hi, thank you for the information, but which "little tweak" was that?

    • 21 posts
    November 3, 2019 12:47 PM EST
    Modify the code to make it work
    • 7 posts
    November 3, 2019 12:55 PM EST

     Maybe you can publish this modify code here ;-) for helping others with that problem?

    • 63 posts
    November 3, 2019 10:05 PM EST

    I have been using mariadb with SE for a while....