Community

Forums » SEPHP Help and Tips

Payment settings problem after upgrade to SE 4.10.5

    • 3 posts
    October 31, 2019 7:20 PM EDT
    <pre>With the new upgrade,it seems the lib MCrypt is no longer compatible with PHP7.3<br>and as a result the payment system on Socialengine is not working. Does someone know what is the way out<br>as this has actually render our site useless for days now.<br>here is the error message I receive below each time I try to setup a payment gateway</pre> <pre>Please help<br><br>#1 /home/zionchur/public_html/afrosky.com/application/modules/Payment/Model/DbTable/Gateways.php(89): Engine_Db_Table->_unserializeColumns(Array) #2 /home/zionchur/public_html/afrosky.com/application/libraries/Zend/Db/Table/Abstract.php(1392): Payment_Model_DbTable_Gateways->_fetch(Object(Zend_Db_Table_Select)) #3 /home/zionchur/public_html/afrosky.com/application/modules/Payment/controllers/AdminSettingsController.php(32): Zend_Db_Table_Abstract->fetchAll() #4 /home/zionchur/public_html/afrosky.com/application/libraries/Zend/Controller/Action.php(516): Payment_AdminSettingsController->indexAction() #5 /home/zionchur/public_html/afrosky.com/application/libraries/Zend/Controller/Dispatcher/Standard.php(308): Zend_Controller_Action->dispatch('indexAction') #6 /home/zionchur/public_html/afrosky.com/application/libraries/Zend/Controller/Front.php(954): Zend_Controller_Dispatcher_Standard->dispatch(Object(Zend_Controller_Request_Http), Object(Zend_Controller_Response_Http)) #7 /home/zionchur/public_html/afrosky.com/application/modules/Core/Bootstrap.php(84): Zend_Controller_Front->dispatch() #8 /home/zionchur/public_html/afrosky.com/application/libraries/Engine/Application.php(160): Core_Bootstrap->run() #9 /home/zionchur/public_html/afrosky.com/application/index.php(223): Engine_Application->run() #10 /home/zionchur/public_html/afrosky.com/boot.php(47): include('/home/zionchur/...') #11 /home/zionchur/public_html/afrosky.com/index.php(24): Engine_Boot->boot() #12 {main}</pre>
    • 3742 posts
    October 31, 2019 7:51 PM EDT

    The requirements mention not to use php 7.3 as it is not compatible. Please do not use php 7.3.

    • 3 posts
    October 31, 2019 8:11 PM EDT

    I saw your suggestion somewhere to a member to apply the below code to his database, and I did apply that to MySql database to clear the Paypal info and it worked like a charm.

    UPDATE `engine4_payment_gateways` SET `config`= null WHERE `title` = 'PayPal';

    My two weeks problem has been solved 

    Thank You very much

    • 3742 posts
    November 1, 2019 7:31 AM EDT

    Great that it worked for you :) . There are other issues with PHP 7.3 and we do not provide support for resolving those as we need to do some fixes to have it work. so you may still want to go back to 7.2 instead.