Forums » SEPHP Help and Tips

How do I add a favicon

    • 187 posts
    November 5, 2019 1:58 PM EST

    I am following the instructions found in the following link but my ACP does not look like the ACP in the link: https://www.socialengine.com/support/article/8716318/adding-a-logo-and-favicon

    • 21 posts
    November 6, 2019 12:29 AM EST

    You probably has the PHP version of SE. If so, simply resize any images, preferably .png extension to 16 x 16 pixels. Then rename the file to favicon.ico and then upload it to the root directory of your SE site (usually httpdocs). To verify go to your site domain.com/favicon.ico just like how https://community.socialengine.com/favicon.ico

    • 3741 posts
    November 6, 2019 7:08 AM EST

    The tutorial you linked is for SocialEngine Unite. When searching for tutorials, please make sure the one you select is for the product you are using. Here is the tutorial for SEPHP:

    https://www.socialengine.com/support/article/5243181/se-php-creating-and-adding-a-favicon

    • 187 posts
    November 7, 2019 7:46 PM EST

    I did it and it is not working.  I have taken a screenshot to show you the file has been uploaded into the "externals" folder. 

     

    • 21 posts
    November 8, 2019 12:25 AM EST

    it should not be in "external" folder, it should in the same level folder as "external" folder. So it should be in "public_html" folder

    • 187 posts
    November 8, 2019 8:31 AM EST

    Ok.  I have now placed the favicon file into the public html file (see screenshot).  It is still not working.

     

    • 3741 posts
    November 8, 2019 2:10 PM EST

    Please double check the instructions as they show the file type you need in a screenshot and in a note at the bottom of the linked tutorial. You have "Favicon WRTH.iso" which is not a favicon. A favicon needs to be named favicon.ico  . 

    • 187 posts
    November 12, 2019 7:35 PM EST

    As you can see from the screenshot the favicon.ico file is now in the correct place but the favicon is still not working.  I have cleared the browsing data/cache.

    • 21 posts
    November 13, 2019 12:21 AM EST

    I dont know if lowercase favicon.ico and Favicon.ico making any differences but i would change it to lowercase. If everything is correct you should be able to view this icon in the browser as domain.com/favicon.ico

    • 3741 posts
    November 13, 2019 5:39 AM EST

    It needs to be lower case as the instructions show. Also, clear browser cache.

    • 187 posts
    November 13, 2019 10:28 AM EST

    Lowercase added.  See screenshot.  Cache cleared.  Favicon still not showing.  Favicon not showing at domain.com/favicon.ico

     

    • 187 posts
    November 13, 2019 10:29 AM EST

    Any ideas?

    • 21 posts
    November 14, 2019 12:03 AM EST

    if its not showing when you go to domain.com/favicon.ico then what does it show?

    • 3741 posts
    November 14, 2019 6:33 AM EST

    When visiting your favicon, it says it shows errors. Are you sure you used a program to create the favicon.ico file correctly? Perhaps recreate it using a program that can save favicon.ico files such as the free Gimp program or use the linked one in the tutorial.

    • 187 posts
    November 14, 2019 4:31 PM EST

    I used GIMP like the tutorial suggested.  The instructions beyond that are sparse in the tutorial.  The tutorial simply states "It has an export tool to create ico images."  You will see the steps I took in the screenshots below. First I tried export as favicon.ico.  That file did not work.  Then I tried Export as... and changed the extension to .ico.  That file did not work either.  Please let me know what I can do to fix this problem. I have also added the screenshot that is showing for werunthehouse.org/favicon.ico.

    I must say that adding a simple favicon is an incredibly complicated and elaborate process!  Can't SE make it easier???