Community

Forums » 3rd Party Product Discussions

Member issues deleting their own account error help please

    • 4 posts
    November 19, 2019 5:20 PM EST

    Hello, 

    Our SE site is having some issues with certain member accounts not being able to delete their own account. 

    Attached is a screenshot of the error being encountered. Although the error code does change each time it is attempted. 
     
    If needed, I am happy to provide the member's account logins for the account that brought this to our attention. 
     
    Many thanks in advance for any guidance on this issue..
     

    This post was edited by Nelson at November 21, 2019 2:36 PM EST
    • Moderator
    • 3861 posts
    November 21, 2019 6:03 AM EST

    You should remove the email as it'll make you a target for spam or who knows as this is a public forum. Please post the actual error as error codes are random numbers and letters that correspond to the same series in your error log. That will help to see what the issue is. Also post the version of SEPHP and whether you are using third party plugin for user stuff. Oh and when posting any errors, use the code symbol right next to the smiley symbol and please remove any private info in order to be safer.

    • 4 posts
    November 21, 2019 2:55 PM EST

    Hi Donna,


    Thanks for your response. I removed the email as you suggested. My SE version is 4.10.3p5. Re: plugins.. I really don't know if I am using 3rd party plugin for user stuff, but I certainly am using quite a few 3rd party plugins. Maybe that is the same thing you're asking?

    Also, not sure at all what smiley face you're referring to with the error codes?

    Do you work for SE? Depending on what my response tells you, if needed and possible, I'd be open to compensating you for your time to look deeper. 

    Nelson


    This post was edited by Nelson at November 21, 2019 2:56 PM EST
    • Moderator
    • 3861 posts
    November 22, 2019 5:45 AM EST

    Hi Nelson,

    Yes, I'm ChiefEvangelist for SE. :) Only official SE employees can use the SE icon for the profile pic here so as to distinguish SE official folks from clients and experts here. Hope that helps you to know an official staff member here from others. 

    If you look at the editor here when you are typing stuffs, you see there a lots of buttons up there to use for formatting. This is actually mentioned in our forum rules that are stickied in various forum sections so folks know what they should and shouldn't do here. On that button area, on the top row, you'll see a link icon, an eyeball, a smiley face and lastly the icon for adding code. Click that icon for adding code whenever you want to add error messages or code snippets.

    So, if you go to your log browser and click to see the error log, it'll have a long list probably. Download that. Then, find the same error code that corresponds to the one in your screenshot. Then copy and paste that into the forum (using that code button first). 

    Or, if you have support, send us a ticket and I can look at it but since you are not upgraded, you first need to upgrade in order to receive support. Before doing that, check with third party experts as some third party products will break the upgrade.

    No need for compensation. My help here is free. :)

    • 4 posts
    December 5, 2019 4:40 PM EST

    Hello Donna,

    Sorry for taking so long to get the code. My developer was confused about the account in question, but we finally figured it out. 

    The code is entered here to the code area, as you explained to add.

    Thanks!
    Nelson

    2019-12-05T10:07:16+00:00 ERR (3): Error Code: d942be Error: Call to a member function getType() on null in /var/www/html/application/modules/Core/Model/Comment.php:123 Stack trace: #0 /var/www/html/application/libraries/Zend/Db/Table/Row/Abstract.php(632): Core_Model_Comment->_postDelete() #1 /var/www/html/application/modules/Advancedactivity/Plugin/Core.php(156): Zend_Db_Table_Row_Abstract->delete() #2 /var/www/html/application/libraries/Engine/Hooks/Dispatcher.php(224): Advancedactivity_Plugin_Core->onItemDeleteBefore(Object(Engine_Hooks_Event)) #3 /var/www/html/application/modules/Core/Model/Item/Abstract.php(583): Engine_Hooks_Dispatcher->callEvent('onItemDeleteBef...', Object(Engine_Hooks_Event)) #4 /var/www/html/application/modules/User/Model/User.php(416): Core_Model_Item_Abstract->_delete() #5 /var/www/html/application/libraries/Zend/Db/Table/Row/Abstract.php(610): User_Model_User->_delete() #6 /var/www/html/application/modules/User/controllers/SettingsController.php(592): Zend_Db_Table_Row_Abstract->delete() #7 /var/www/html/application/libraries/Zend/Controller/Action.php(516): User_SettingsController->deleteAction() #8 /var/www/html/application/libraries/Zend/Controller/Dispatcher/Standard.php(308): Zend_Controller_Action->dispatch('deleteAction') #9 /var/www/html/application/libraries/Zend/Controller/Front.php(954): Zend_Controller_Dispatcher_Standard->dispatch(Object(Zend_Controller_Request_Http), Object(Zend_Controller_Response_Http)) #10 /var/www/html/application/modules/Core/Bootstrap.php(84): Zend_Controller_Front->dispatch() #11 /var/www/html/application/libraries/Engine/Application.php(160): Core_Bootstrap->run() #12 /var/www/html/application/index.php(223): Engine_Application->run() #13 /var/www/html/boot.php(47): include('/var/www/html/a...') #14 /var/www/html/index.php(24): Engine_Boot->boot() #15 {main}
    • Moderator
    • 7 posts
    December 6, 2019 12:14 AM EST

    Hello Nelson,

     

        The log error is coming from some 3rd party developer "Advancedactivity" module installed on your website. So, kindly once contact the developer of this module to get it checked.

    Regards

    Shubhra

    • 4 posts
    December 6, 2019 7:37 PM EST

    Thanks so much Shubhra! Will post update when my developer looks into it.