Forums » SEPHP Help and Tips

Install SocialEngine PHP 5.0.0rc1! Gets Stuck

    • 30 posts
    January 24, 2020 12:25 PM EST

    Hello,

    I am trying to test out the new version and when installing It gets stuck at create-db

    I have to edit the .htaccess file and change   Options +SymLinksifOwnerMatch

    It looks like it install then 500 error.

    I never get to enter in the admin username and pw.

    Please help.

    Thanks in advance

    $Id: .htaccess 9977 2013-03-19 20:51:56Z john $ Options +SymLinksifOwnerMatch #Options +FollowSymLinks RewriteEngine On # Get rid of index.php RewriteCond %{REQUEST_URI} /index\.php RewriteRule (.*) index.php?rewrite=2 [L,QSA] # Rewrite all directory-looking urls RewriteCond %{REQUEST_URI} /$ RewriteRule (.*) index.php?rewrite=1 [L,QSA] # Try to route missing files RewriteCond %{REQUEST_FILENAME} !-f RewriteCond %{REQUEST_FILENAME} public\/ [OR] RewriteCond %{REQUEST_FILENAME} \.(jpg|gif|png|ico|flv|htm|html|php|css|js)$ RewriteRule . - [L] # If the file doesn't exist, rewrite to index RewriteCond %{REQUEST_FILENAME} !-f RewriteCond %{REQUEST_FILENAME} !-d RewriteRule ^(.*)$ index.php?rewrite=1 [L,QSA] # sends requests /index.php/path/to/module/ to "index.php" # AcceptPathInfo On # @todo This may not be effective in some cases FileETag Size AddOutputFilterByType DEFLATE text/text text/html text/plain text/xml text/css application/x-javascript application/javascript

     


    This post was edited by SNS-Shubhra at January 25, 2020 8:10 AM EST
    • Moderator
    • 42 posts
    January 25, 2020 8:15 AM EST

    Hello mattwales,

     

         It seems your .htaccess file is modified and is not the same which comes from SocialEngine. Please check with the default .htaccess file, if you are still facing the issue.

    I am placing the code below for your reference.

     

    # $Id: .htaccess 9977 2013-03-19 20:51:56Z john $ <IfModule mod_rewrite.c> Options +FollowSymLinks RewriteEngine On # Get rid of index.php RewriteCond %{REQUEST_URI} /index\.php RewriteRule (.*) index.php?rewrite=2 [L,QSA] # Rewrite all directory-looking urls RewriteCond %{REQUEST_URI} /$ RewriteRule (.*) index.php?rewrite=1 [L,QSA] # Try to route missing files RewriteCond %{REQUEST_FILENAME} !-f RewriteCond %{REQUEST_FILENAME} public\/ [OR] RewriteCond %{REQUEST_FILENAME} \.(jpg|gif|png|ico|flv|htm|html|php|css|js)$ RewriteRule . - [L] # If the file doesn't exist, rewrite to index RewriteCond %{REQUEST_FILENAME} !-f RewriteCond %{REQUEST_FILENAME} !-d RewriteRule ^(.*)$ index.php?rewrite=1 [L,QSA] </IfModule> # sends requests /index.php/path/to/module/ to "index.php" # AcceptPathInfo On # @todo This may not be effective in some cases FileETag Size <IfModule mod_deflate.c> AddOutputFilterByType DEFLATE text/text text/html text/plain text/xml text/css application/x-javascript application/javascript </IfModule>

     

     

    I am moving it to the correct category as this one is for SocialEngine staff only.

    And I have also edited your post to put the code in Code tag as posted in our posting guidelines. Please use the code tag next to smiley in your replies and posts to place code.

    • 30 posts
    January 27, 2020 3:52 PM EST

    Hi Shubhra,

    Sorry for posting in the wrong section and thanks for the reply.

    If I don't modify the .htaccess file with Options +SymLinksifOwnerMatch

    I get a 500 Error.

    I'm looking in on how to turn this off on my Ubuntu server running virtualmin

    Please let me know if you have any suggestions.

    Thanks again.

    Matt

     

     

     

    • Moderator
    • 5214 posts
    January 28, 2020 4:27 AM EST

    We had at one point changed to SymLinksIfOwnerMatch but had to revert back to FollowSymLinks as the other broke. I'm also not sure if your typo in your code is causing any issue as you have SymLinksifOwnerMatch with a lowercase "i". Anyway, at this time we don't recommend changing it unless you try to resolve the issues. FollowSymLinks is what works right now. Make sure the server has it enabled. Many don't. Also, make sure you are not above PHP 7.2.

    • 171 posts
    January 28, 2020 9:42 AM EST
    mattwales said:

    Hi Shubhra,

    Sorry for posting in the wrong section and thanks for the reply.

    If I don't modify the .htaccess file with Options +SymLinksifOwnerMatch

    I get a 500 Error.

    I'm looking in on how to turn this off on my Ubuntu server running virtualmin

    Please let me know if you have any suggestions.

    Thanks again.

    Matt

     

     

     

    See this for a possible solution.

    https://www.virtualmin.com/comment/741442#comment-741442

    If you are on Virtualmin and are the root user AND you are the only user on the server, the risk of applying this fix is pretty minimal.

    • 30 posts
    February 1, 2020 11:10 AM EST

    Thanks for the info. I got it to work with the link.

    I appreciate the great help and caring here.

    THANK YOU

    • Moderator
    • 5214 posts
    February 1, 2020 1:05 PM EST

    That's great! Glad you got it solved. :)