Forums » SEPHP Help and Tips

Activity Feed | Auto Refresh ?

    • 256 posts
    April 6, 2020 8:30 PM EDT

    Just noticed my activity stream is not auto refreshing. Thoughts on this error code.

    2020-04-06T16:22:49+00:00 ERR (3): Error Code: 28b712 Zend_Controller_Action_Exception: Context "feed" does not exist in /home//public_html/application/libraries/Zend/Controller/Action/Helper/ContextSwitch.php:532 Stack trace: #0 /home//public_html/application/libraries/Zend/Controller/Action/Helper/ContextSwitch.php(1239): Zend_Controller_Action_Helper_ContextSwitch->hasContext('feed', true) #1 /home//public_html/application/libraries/Zend/Controller/Action/Helper/ContextSwitch.php(257): Zend_Controller_Action_Helper_ContextSwitch->hasActionContext('error', 'feed') #2 /home//public_html/application/modules/Core/Controller/Action/Helper/ContextSwitch.php(105): Zend_Controller_Action_Helper_ContextSwitch->initContext(NULL) #3 /home//public_html/application/modules/Core/Controller/Action/Helper/ContextSwitch.php(90): Core_Controller_Action_Helper_ContextSwitch->initContext() #4 /home//public_html/application/libraries/Zend/Controller/Action/HelperBroker.php(265): Core_Controller_Action_Helper_ContextSwitch->preDispatch() #5 /home//public_html/application/libraries/Zend/Controller/Action.php(500): Zend_Controller_Action_HelperBroker->notifyPreDispatch() #6 /home//public_html/application/libraries/Zend/Controller/Dispatcher/Standard.php(308): Zend_Controller_Action->dispatch('errorAction') #7 /home//public_html/application/libraries/Zend/Controller/Front.php(954): Zend_Controller_Dispatcher_Standard->dispatch(Object(Zend_Controller_Request_Http), Object(Zend_Controller_Response_Http)) #8 /home//public_html/application/modules/Core/Bootstrap.php(84): Zend_Controller_Front->dispatch() #9 /home//public_html/application/libraries/Engine/Application.php(160): Core_Bootstrap->run() #10 /home//public_html/application/index.php(223): Engine_Application->run() #11 /home//public_html/boot.php(47): include('/home//...') #12 /home//public_html/index.php(24): Engine_Boot->boot() #13 {main}
    • Moderator
    • 5235 posts
    April 7, 2020 5:19 AM EDT

    Well that is odd. I'll go check the demo for that error. In the mean time, when you upgraded did you see any issues at all? Did you ever have any third party plugin for the feed? Some of them did alter the databases and cause upgrade issues. Just trying to figure out what's going on there.

    • Moderator
    • 5235 posts
    April 7, 2020 5:33 AM EDT

    I checked and that error isn't on the demo. I then tested and the feed appears to auto update fine for me. It isn't instant but it does do it under a minute. I didn't actually time it as to how many seconds it took though.

    • 256 posts
    April 7, 2020 7:08 AM EDT

    Hello Donna,

    Thanks for checking. I am still using version 4.10.3p5.

    I had just completed my project when SE announced the discontinuation of PHP.

    I have not updated anything or made any changes since that time.

    The workload of updating since the SE reversal has escaped me.

    Now with #stayhome my traffic has jumped and now have several thousand new members.

    I guess I was looking for a simple solution :)

    • Moderator
    • 5235 posts
    April 7, 2020 7:27 AM EDT

    I don't have that error on my own site which I hadn't had time to upgrade. Did it ever upgrade to the version you are on? If so, could the upgrade have had a snag?

    • 256 posts
    April 7, 2020 8:05 AM EDT

    My last update was months +++ ago, maybe a year. No theme or plugin updates. I think in the last year the only changes were new users :) I check my error logs daily though and its brand new - but no explanation :(

    • Moderator
    • 5235 posts
    April 7, 2020 9:37 AM EDT

    In that case it must be a server change or update. As you are on an older version, you can check the old requirements as the new ones might not apply.

    https://www.socialengine.com/support/article/5210530/se-php-socialengine-requirements-versions-below-4.10.5 it might be that one. I don't know if 4.10 supports PHP 7.2. It does support PHP 7.0. It could support 7.2 but I'm not in my own site admin atm to check.

    Also, make sure you are not on mariadb. We have never supported that. 

    You might want to consider upgrading to v5. 

    • 256 posts
    April 7, 2020 9:55 AM EDT

    I want to upgrade (I haven’t seen a lot of changes with V5 though). The work of updating SE isn’t really the issue but more so the work of updating the theme and plugins from 1 third party I use and the expected bugs. I use php 7.1.33 right now. I am pondering smile.png


    This post was edited by Miami Shade at April 7, 2020 10:43 AM EDT
    • Moderator
    • 5235 posts
    April 7, 2020 10:46 AM EDT

    There are quite a lot of changes in v5 and 5.0.1. Lots of bugs fixed, security improvements, free mobile apps, new responsive theme, the two step authentication, way too many to go into here lol.

    https://www.socialengine.com/blog/2020/01/29/socialengine-php-5-0-released

    https://www.socialengine.com/blog/2020/03/04/socialengine-php-5-0-1-released

    • Moderator
    • 5235 posts
    April 7, 2020 10:47 AM EDT

    Yeah though, the issue of upgrading with plugins can be hairy but if your dev has updated their plugins and you bought from the SE store, the plugins shouldn't have core changes so it should be ok. Best to update a dev clone first and see how it goes.

    • 256 posts
    April 8, 2020 5:40 PM EDT

    OK Thanks @Donna,

    I have decided to update but I may wait until 5.1 is out so most the bugs will be fixed.

    Is there an expected date for that?

    • Moderator
    • 5235 posts
    April 9, 2020 6:09 AM EDT

    Well, we generally don't give dates but I can say that we are final testing things.