Forums » SEPHP Help and Tips

You can modifying your terms of service

    • 205 posts
    July 7, 2020 5:07 PM EDT

    You can modifying your terms of service by editing the _CORE_TERMS_OF_SERVICE language variable in the application/languages/en/core.csv file.

     

    Where can I find this file so I can edit the terms of service?

    • Moderator
    • 5213 posts
    July 7, 2020 5:55 PM EDT

    You don't need to do it there. You can do it in the phrase manager. That is where I always do it for the demo and here. https://www.socialengine.com/support/article/5112039 shown there, I just search for "terms" without quotes. 

    Doing it via the file instead can cause site issues if not done correctly. You'll need to be careful if you edit it that way. You showed the path to the file in your question. It is on the server in the path you mentioned but again, I wouldn't edit that file and would instead do it via the phrase manager.

     

    • 7 posts
    August 18, 2020 2:26 PM EDT

    Hi there, this is my first question in this forum: I am a bit confused with the proper way to have working "terms of service" and "privacy policy" pages.

    I am working with a SE PHP network on English (default) and Spanish. At the Appearance > Layout  > Editing: Terms of Service Page I was able to produce a fine html page. However it was only shown in English and I found not way to make it appear if Spanish is selected even including the translation in the .csv files at languages/es and generating the es.php array . After searching the Forum I found an entry saying to change "_CORE_TERMS_OF_SERVICE" at the language manager. I did it but my language manager has not save button so I changed it inside the language/en/core.csv and generated a new en.php array: it does not change the terms of service page and only change what appears at the anguage manager. So, at this point I have no idea how can I get working "terms of service" (and "privacy policy") pages working both in English and Spanish.

    It seems I need some help. Thanks in advance.

    • Moderator
    • 5213 posts
    August 19, 2020 5:20 AM EDT

    I would not change it via files as I said. I would do it in the file manager. Make sure you edit both languages in the file manager. The English and the Spanish. Then, clear cache. Since you already set the array via translation performance, you'll need to click that in cache as well. I don't use that setting. Anyway, you then should check the site front end by changing the language for your user front end. It should work fine via the file manager unless your file edits messed up the files.


    This post was edited by Donna at August 19, 2020 5:21 AM EDT
    • 7 posts
    August 19, 2020 7:30 AM EDT

    Thanks Donna, I still have the problem that the language manager shows not saving button. In the .htaccess file I included:  

       SecFilterEngine Off

       SecFilterScanPOST Off

     

    But stills it doesn't shows the save button.

    • 7 posts
    August 19, 2020 7:32 AM EDT

    This editor has not included: IfModule mod_security.c and IfModule between less than and larger than signs ...

    • Moderator
    • 5213 posts
    August 19, 2020 8:13 AM EDT

    Per the requirements, please disable mod_sec


    This post was edited by Donna at August 19, 2020 8:13 AM EDT
    • 313 posts
    August 20, 2020 6:25 AM EDT

    Hei Folks..

    Whatonearth, Ticita.

    Mikel here.

    I am reading the conversation. I to had the same confusion that you all seem to have. Although i did learn to alter the 'Terms of service' , 'privacy' in language manager, 

    I learned a quick / cheat way of setting your terms and privacy without using the 'language manager'

    What i did: 
     I created 2 new pages in my footer  ( 'terms of service' and 'privacy' ) using 'layout' also 2 new tabs in 'menu' and linked them both.
    Now all i do to write / change the info is just go into my layout and choose the page  and alter the info as needed then save.

    It saves me from going through the language manager instructions.

    this works for me very nice. It may work for you.

    Notice: All my text is in Uk English and i do not use translator. so i do not know how this may affect translation.

    It may help you, if you choose to experiment with my way.

    If you want to see some screen shots of how i did it, let me know. You can copy what i did.

    thanks

    mikel.


    This post was edited by mikel at August 20, 2020 6:27 AM EDT
    • 7 posts
    August 20, 2020 6:39 AM EDT

    Thanks Donna and Mikel.

    mod_sec disabled. Still no saving button at the languages manager.

    Mikel: will follow your advise and report. 

    Cheers,

    Tacita

    • Moderator
    • 5213 posts
    August 20, 2020 8:10 AM EDT

    Ae you sure before changing phrases that you turned off the translation performance setting? After doing the phrase and saving it, turn it back on if you want to use it. I don't use it. If you still don't have a save button and are using html, perhaps some html you are using is not allowed. Try a basic phrase change first and if that works, you need to change your html.

    • 7 posts
    August 21, 2020 3:12 PM EDT

    I followed both lines of advice: 

    1- Mikel's: Created new entries  in the menu editor with Terms and Privacy pages for Spanish entries and linked them to new pages in the layout editor. Then ended with four entries in the footer and the problem turned now into how to change the footer to show only those of the selected language.

    2- Donna's: I was able to get the saving button working after unticking the php matrix generation at Performance & Caching and -after deleting those changes in Mikel's way in 1- on the Language Manager edited the CORE_TERMS_OF_SERVICE macro to contain a sample text both in english and spanish. None of them worked at all. I reviewed languages/en/custom.csv and es/custom.csv and both of them contain "CORE_TERMS_OF_SERVICE";"My text" properly. 

    After analyzing this problem further I realized that at the menu editor in the footer menu the Terms of Service and the Privacy items are both addressing to /help/terms and /help/privacy. This is in contrast with the address shown in the layout editor's Terms of Service Page where the Page Info says the URL is addressing to /pages/terms 

    If that is the origin of my problem it could be solved with a symbolic link between both address, something I will try now.

    Cheers 

     

    • Moderator
    • 5213 posts
    August 22, 2020 5:12 AM EDT

    That is the normal url to the terms and privacy. I am not sure what is going on with your site but you seem to be making a simple process very complex. I would suggest to try a local development site to see how it works and then figure out how it broke on your site. You can see here on this site the url to both pages. I did the same steps from the tutorial when changing terms and privacy here, on my site, on my demo, on our demo, etc. 

    • 7 posts
    August 25, 2020 6:39 PM EDT

    I am not doing anything different than what is suggested in previous posts. 

    And it is not working for a clean installation (5.2.1).

    I can see that CORE_TERMS_OF_SERVICE is translated in  modules/Core/views/scripts/help/terms.tpl 

    and I would like to know which controller works with it or if is being handled by some locale.php.

    • Moderator
    • 5213 posts
    August 26, 2020 4:55 AM EDT

    The thing is, I have to re-translate the demo every time we reset it which is frequently. I do the same process. I go to the language editor. I search for the core terms and core privacy. I add my html stuff. Save. Clear cache and it works. We do not use the translation performance. Using that requires extra steps such as disabling it. Doing the translation. Clearing cache and clicking to re-do the translation performance. I believe those are the steps for bringing in new phrases if using that feature.  

    I just did the demo again and it worked. Perhaps there is something in your html that isn't allowed and causing an issue. I do know that if there are bad characters in the language file, it will break. I've seen issues with clients manually doing translations and having extra characters that caused an issue. 

    Here is the html that I used, as an example. It is very basic. Maybe try restoring the default translation in case there's something up with yours.

    <p>Hello! Webligo Developments, LLC. provides the website located at demo.socialengine.com (the “Network”). Please read the <a href="https://www.socialengine.com/policies/1147501/privacy-policy" target="_blank">Privacy Policy</a> carefully because it governs your use of the Network and services accessible via the website.</p>
    
    • 7 posts
    August 26, 2020 7:48 PM EDT

    I see. I have followed that exact order and still not working. 

    The only way I can make terms to appear is using Layout editor but I only can add a single language page there.

    I am worried if the reason the CORE_TERMS_OF_SERVICE is not being rendered may be related with the EN/ES plugin I am using. The es/manifest.php file says it is for version 4.10, but even so I can understand why it does not show the terms is the macro is properly defined for English. By the way I have been working with plain text and tried also with the simple html you provided with no success. 

    • Moderator
    • 5213 posts
    August 27, 2020 4:52 AM EDT

    Have you tried removing the other pack or testing on a fresh install on a development site? You are allowed a development site but it must either be on your local computer or on the same domain as the license in a domain named development. If on a server, it must be in a password protected directory or with maintenance mode enabled which requires a code for access. Once you have a fresh install, try changing the phrase without doing any other stuff you did before. 


    This post was edited by Donna at August 27, 2020 4:52 AM EDT