Forums » SEPHP Help and Tips

SE PHP V5 - Description are not in English

    • 57 posts
    July 17, 2020 2:42 AM EDT

    Hello Donna, 

    I just installed the new SEPHP V5, I noticed descriptions are not displaying correcting in English for the entire site, please see attached screenshots. Any idea?

     

    • Moderator
    • 5073 posts
    July 17, 2020 4:02 AM EDT

    This looks to be a site issue as this site is fine and the demo is fine. Please check your settings for translation performance. Is that enabled? Are you sure you are on the normal english pack and not something else? 

    • 164 posts
    July 17, 2020 6:19 AM EDT

    When having a similar issue in the past, I found the following helpful:

     

    1) Go to Admin Panel, select "Development Mode" in the bottom right.

     

    2) Admin Panel > Performance and Caching, tick flush cache and untick the language array option, then click Save.

     

    3) Admin Panel > Performance and Caching, tick flush cache again and re-tick the language array option, then click Save.

     

    4) Go to the Admin Panel home page, and select 'Production Mode' in the bottom right.

     

    (The switching to Development Mode might be unnecessary, but I included it anyway).

    • 57 posts
    July 17, 2020 12:18 PM EDT
    Donna said:

    This looks to be a site issue as this site is fine and the demo is fine. Please check your settings for translation performance. Is that enabled? Are you sure you are on the normal english pack and not something else? 

    Hello Donna,

    You are right, I just installed as test again SE5.1 and it is fine, so this issue started after installing the SocialNetworking.Solutions plugin: SES- Multiple Language - Now, facing this issue I remember this happened previously, since I got tired of reporting and asking them to fix the text that was not in reading English, I decided to manually translate all to Spanish. Anyways, I verify the Performance & Caching and ENABLED the "translation performance" option, I don't know what do you mean for normal English pack, I using the english that came on SE and just add Spanish pack. What else I need to do ?


    This post was edited by Angel at July 17, 2020 12:22 PM EDT
    • 57 posts
    July 17, 2020 12:19 PM EDT
    abuk said:

    When having a similar issue in the past, I found the following helpful:

     

    1) Go to Admin Panel, select "Development Mode" in the bottom right.

     

    2) Admin Panel > Performance and Caching, tick flush cache and untick the language array option, then click Save.

     

    3) Admin Panel > Performance and Caching, tick flush cache again and re-tick the language array option, then click Save.

     

    4) Go to the Admin Panel home page, and select 'Production Mode' in the bottom right.

     

    (The switching to Development Mode might be unnecessary, but I included it anyway).

    Hello Abuk,

    I appreciate your guidance, just it did not work :( 

    • 73 posts
    July 17, 2020 1:13 PM EDT

    step 1. Admin Panel > Language Manager >  [en] edit phrases > edit click > 

    step 2. search USER_VIEWS_SCRIPTS_ADMIN....

    step 3. result No phrases found. >> Originally, such a string was not created. There's a way don't be disappointed.

    step 3-1. result >> find string >> Now you can see that it can be created manually. Rest assured.

    step 4. select spanish lang

    step 4-1 Check if there is no string. [spanish] edit phrases > edit click > (search USER_VIEWS_SCRIPTS_ADMIN....)

    step 4-2 If not, you can make it. Download the file(export click) and open it.(notepad or excel or visual srtudio code or ..etc)

    step5 Create the string and upload it again. (If there is, it will be empty. Fill it in)

    finish ...upload and fix it

     

    If not, please refer to the post above to clear the cache and try again.

     

    There are obvious sentences in the English string, but there is a phenomenon in which this is sometimes omitted. You can do it manually in the Spanish language.

     

    I'm not sure if you want to understand well because the English is poor.

    There is also a way to fix this directly in the Linux shell. I prefer this method.

     

    happy SE


    This post was edited by Lee KiWon at July 17, 2020 1:32 PM EDT
    • 57 posts
    July 17, 2020 9:41 PM EDT

    Hello, I just wanted to share that the issue is already fixed. I believe it was caused because I installed first the Multiple Language instead of the basic required plugin of the third party (my fault), I deleted all and did a fresh install to make sure to install first the plugin in question, so far, it is working. LOL.