Forums » SEPHP Help and Tips

Changing the default "Show invisible characters" setting

    • 43 posts
    July 18, 2020 12:08 AM EDT

    I am looking everywhere but i can't find it. Does anyone know where i can change the setting ("Show invisible characters") to always be turned on by default instead of the default now, that is off.

     

    TinyMCE: 

     

    Thank you.

    • Moderator
    • 5073 posts
    July 18, 2020 4:36 AM EDT

    That doesn't look like default tinymce. It must be a thrid party plugin. Default is like you see here. There are no options like you show in the default. Or, you did a customization to enable those things.

    • 43 posts
    July 18, 2020 4:51 AM EDT

    I did not customise anything myself. This is the FAQs plugin (SocialEngineAddons) and its basic installed by me. Do you think they changed something?


    This post was edited by Michael at July 18, 2020 5:09 AM EDT
    • Moderator
    • 5073 posts
    July 18, 2020 5:08 AM EDT

    You will need to get with them to change that as it is not default to SocialEngine. They must have activated additional TinyMCE features. I would say to remove that file upload option too as in the past those were prone to hacking. Unless it's been fixed by tinymce lately. I'll move this post to the third party area later today.

    Feel free to post a new thread in the 3rd party discussion area for a review of that plugin. It might spur them on to fix the bugs. Just please make it constructive. Plain facts are best. 

    • 43 posts
    July 18, 2020 5:20 AM EDT

    Sorry Donna, i removed that part of SocialEngineAddons. Not the pace to work that out. Thanks do.

    You are talking about "file upload" but where do you see that? I only have a "upload a image" for pictures. Do you mean that? If so i see it here too.

    Under the "File" menu there is no upload. Only new doc, print and restore last draft.

    Here is the full screenshot of it as it is right now.

    • Moderator
    • 5073 posts
    July 18, 2020 5:21 AM EDT

    Ok I thought it was under tools or insert. If not, then that's good. 

    • 164 posts
    July 18, 2020 10:02 AM EDT

    Is it still TinyMCE4 rather than five?

     

    If so, it doesn't look like there is a way to enable visual characters by default.

    https://www.tiny.cloud/docs-4x/plugins/visualchars/

     

    You might be able to get away with using visual blocks though

    https://www.tiny.cloud/docs-4x/plugins/visualblocks/

     

    I have done a search to see if there is an undocumented visualchars_default_state setting, as it exists in TinyMCE5. I've just done this, and it appears that the features was requested in 2018:

     

    https://github.com/tinymce/tinymce/issues/4643

     

    And it looks like the feature was added in 4.9.4:
    https://diff.intrinsic.com/tinymce/4.8.5/4.9.4

     

    So maybe try enabling the visualchars_default_state setting by adding it to your TinyMCE initiator?

     

    I don't have the code for that pluginso I can't tell you where you need to add it.

     

    Edited post as it appears the visualchars_default_state setting was added in 4.9.4.

     


    This post was edited by abuk at July 18, 2020 10:11 AM EDT
    • 43 posts
    July 18, 2020 11:12 AM EDT

    @Abuk, Thank you. I'll have a look at it.