Forums » SEPHP Help and Tips

error log

    • 20 posts
    August 26, 2020 3:07 PM EDT

    When I look at the error log in the folder of my web site, it keeps filling up every few seconds. 

    the following pattern keeps repeating:

    [26-Aug-2020 18:38:20 UTC] PHP Warning:  "continue" targeting switch is equivalent to "break". Did you mean to use "continue 2"? in /home/veloviec/public_html/application/modules/Authorization/Api/Core.php on line 143
    [26-Aug-2020 18:38:59 UTC] PHP Warning:  "continue" targeting switch is equivalent to "break". Did you mean to use "continue 2"? in /home/veloviec/public_html/application/libraries/Zend/Form.php on line 1173
    [26-Aug-2020 18:38:59 UTC] PHP Warning:  "continue" targeting switch is equivalent to "break". Did you mean to use "continue 2"? in /home/veloviec/public_html/application/libraries/Zend/Form.php on line 1690<br><br>With the COVID, there isn't much trafic going on our web site as our activities have been cancelled.<br><br>Any idea on what could be the cause?<br><br>Thanks,
    • Moderator
    • 5236 posts
    August 27, 2020 4:53 AM EDT

    What version of SEPHP do you have? What version of PHP is on your server? Are you using mysqli or something else for the database?

    • 20 posts
    August 27, 2020 9:27 AM EDT

    Sorry about that, I thought about it when going to bed last night...

    the site is running 5.2.1 with plugins from SocialApps.tech, all updated to the latest versions.

    The version of PHP is 7.3, but looks like I could switch to 7.4 in MultiPHP. I am not to sure what you mean by SEPHP. 

    The database is MySQL and it is only used for SE.

    • Moderator
    • 5236 posts
    August 27, 2020 9:47 AM EDT

    Please stay within the requirements. SEPHP does not support above 7.2. SEPHP is the product you are using for your site. SocialEngine PHP. 

    • 20 posts
    August 27, 2020 9:55 AM EDT

    I switched the PHP version to 7.2. Errors are still coming in.

    • Moderator
    • 5236 posts
    August 27, 2020 11:05 AM EDT

    More than likely it is from your third party plugins that might not be updated. Check with SocialApps.Tech to see if they can pinpoint the issues. Make sure you are not using mariadb which is a fork of mysql too as it is not supported.

    • 20 posts
    August 28, 2020 11:43 AM EDT

    I did disable all SocialApps.Tech packages on my developement site and the error log is still increasing. Is it enough to say that the problem might not be coming from their package?

    • Moderator
    • 5236 posts
    August 29, 2020 4:39 AM EDT

    No because they modify source and tables. You need to check with them first to see if there are modifications and whether the issues are coming from plugins that need updating to work in PHP 7.2. Also, double check the database as many hosts these days are automatically adding Mariadb which is a fork of Mysql and then telling the client is is mysql. SEPHP does not work well with Mariadb without tweaks. Ask your host about that error to see if any configuration needs to be done on the server as well. Though a google search I just did shows your first post those warnings are in PHP 7.3 so please clear your error log and see what the new errors are. If they still show, double check that PHP 7.3 is not on the site.