Forums » SEPHP Help and Tips

what SE versions does My SQL 5.6 and 5.7 work with?

  • gs
    • 851 posts
    June 12, 2019 9:48 PM EDT

    Presently running MySQL 5.5, but need to upgrade to 5.6 or 5.7 (won't waste tine here explaining why).  Which MySQL version(s) (5.6, 5.7, both) does each of the following SE versions support?  I ask because my host feels SE is ok, but it's possible a theme or Plugin might have an issue (which I don't understand because if a specific SE version is compatible with a MySQL version, then I thought themes/plugins compatible with that SE version would by relation be compatible with the same MySQL version, but obviously I'm no expert). ty.





    • 3408 posts
    June 13, 2019 5:02 AM EDT

    I'm using 4.10.3p5 on local with mysql 5.7.25 without any issue. If you have plugins and themes, it's a good idea to ask those experts. 

    I've not tested 4.09 on the upgraded mysql but I would guess it works. I doubt 4.8 works as it doesn't work on PHP 7 either. Best option would be a development site on local or on your hosts setup but you would end up paying for that as it would need to be on a separate server. They would need to set it up as a subdomain of your main domain to conform to licensing. 

  • gs
    • 851 posts
    June 13, 2019 12:09 PM EDT

    thanks Donna.

    Where may I find the requirements for 4.09 and 4.08?

    In the future could requirements include more specifics, i.e. specific tested versions that work properly rather than unclear 'or newer' ?  'or newer' for PHP and MySQL for example are meaningless unless all 'newer' versions are ok to use (which is obviously not possible to know in advance).  This also could give 3PDs specific requirements/expectations.  Just a thought.

    • 3408 posts
    June 13, 2019 3:37 PM EDT

    We don't have any legacy documentation for versions no longer supported as those versions are not recommended to run due to security fixes that were released. I would suggest to install on local and see what you can use with them but I would guess they should work in 5.7.

  • gs
    • 851 posts
    June 13, 2019 4:08 PM EDT


    • 3408 posts
    June 13, 2019 4:13 PM EDT

    If you remind me Monday, I can see if I can find any info. But it's really not good to run the older versions.

  • gs
    • 851 posts
    June 13, 2019 6:01 PM EDT

    i agree, but there are times when an old install needs to be looked at locally (such as to show/prove how something worked or didn't).  imagine not being able to easily access a word or excel file from only 1-2 years ago.  there are many reasons to look back.

    and looking forward, i will most likely be running the 'old' 4.10.03p5 for years to come before being able to implement Unite, due to numerous 3PD products.

    for some if us, kerping up with SE versions isn't a simple thing.  besides Core, i only use 1 module, but use close to 100 by 3PDs.  so always using the latest is simply not an option :(

    This post was edited by gs at June 13, 2019 6:46 PM EDT