Community

Forums » SocialEngine Product Releases

SocialEngine PHP 4.10.4 Released!

    • Moderator
    • 3528 posts
    July 17, 2019 12:12 PM EDT

    We are happy to announce the release of SocialEngine PHP 4.10.4. This release addresses the bugs listed below.

    Following is a list of fixes in this release:

    Bugs Fixed:

    • Fixed - Error with Send Friend Request for Deleted Invited Users
    • Fixed - Can't delete event or group from admin panel
    • Fixed - Hardcoded phrases
      • application/languages/en/core.csv
        • "'%value%' is more than %max% characters long";"'%value%' is more than %max% characters long"
        • "'%value%' is less than %min% characters long";"'%value%' is less than %min% characters long"
      • application/languages/en/activity.csv
        • "Delete Comment?";"Delete Comment?"
        • "Are you sure that you want to delete this comment? This action cannot be undone.";"Are you sure that you want to delete this comment? This action cannot be undone."
        • "Done";"Done"
      • application/languages/en/invite.csv
        • "Please enter only valid email addresses.";"Please enter only valid email addresses."
    • Fixed - Network Announcement Privacy Not working. We also will improve this in another upcoming release.
    • Fixed - Array to string conversion when changing photo album member level privacy permissions
    • Fixed - Tag Emailed Notification Shows "Array" Instead of Text Phrase
    • Fixed - Fresh Install DB Warning Non-Numeric Value
    • Fixed - Network Link in Admin Panel Opens in Smoothbox
    • Fixed - Wrong caption set when a message is sent to multiple recipients
    • Fixed - No General Settings Link Appears in Mobile
    • Fixed - Future Event Can't be Deleted from Manage Event Page
    • Fixed - Some UI issues in Forum and Private Messages when a site is accessed in the full-site mode via a mobile device
    • Fixed - Issues in Warning Log File
      • Undefined variable: profileTypesArray
      • Undefined variable: contentKey
      • PHP 7.2 count(): Parameter must be an array or an object that implements Countable
    • Fixed - Bad permissions on main.log causes indefinite email loop
    • Fixed - Censored words not censored in Profile Questions.

    A complete changelog is available for more details about the changes and fixes implemented in this 4.10.4 release. 

    As always we highly encourage all users to do a complete backup of both files and database before performing this upgrade. Please have the backup performed by your host or a developer if you’re not comfortable with performing it yourself. Always check with third party experts for compatibility with any products you use before upgrading.

    Important: If you are on version 4.9.4p1 or below, you will need to follow the special steps in the upgrading documents linked below before upgrading and apply the patch mentioned.

    You can download your copy of version 4.10.4 from your client dashboard. Fresh installs should follow our installation tutorial or you can order an installation ticket and our team will get it installed in no time! To upgrade from a previous version to 4.10.4, please view our upgrade documentation or, if you’d rather we take care of the hard stuff, you can order an upgrade and we’ll do it for you.

    If you find any issues, please let us know by filing a bug report in our Bug Tracker. We’d like to encourage you to stay connected with the community.

    What’s Next:

    Our next release will focus on security fixes and improvements. 

    To provide the best and most secure PHP platform, we also need to announce that upon our next release we will remove support for PHP 5.6 and our minimum PHP version supported will move up to 7.2. Also, we will raise our minimum MySQL requirement to 5.7 and remove support for earlier versions. 


    With Great Appreciation,
    The SocialEngine Team


    This post was edited by Donna at July 17, 2019 6:18 PM EDT
    • 30 posts
    July 17, 2019 4:41 PM EDT

    Hello

    "Upgrade Documentation" just takes me to https://www.socialengine.com/support. ; Is there a specific URL for "Upgrade Documentation"?

    SE PHP

    Thanks Gary

    • Moderator
    • 3528 posts
    July 17, 2019 6:21 PM EDT

    When at the learning center link that you show, are you able to see this:

    If not, can you please let us know the browser and OS you are using so we can fix it? The tutorials should show below the search box on the page. If they aren't, we do need to fix it. Thank you!

    Also, you can reach the upgrade tutorial here at this link: https://www.socialengine.com/support/article/5145140/se-php-performing-upgrades

    • 242 posts
    July 18, 2019 11:30 AM EDT

    4.10.4 Vow! Recent SocialEngine upgrades have been evolutionary. These upgrades have made SE PHP a robust CMS, building a Social Community has evolved from a hobby to a thriving business for the users. 


    Continuing with this, all SocialEngineAddOns Plugins are now compatible with the latest SE 4.10.4 
    We always recommend using upgraded version of the software being used.

    Read the Blog Post for more details on this. In case of any queries, Contact Us.

    Thanks!

    • 30 posts
    July 18, 2019 11:33 AM EDT

    Hi SocialEngineAddOns I'll be contacting today or tomorrow. Thanks Gary

    • 242 posts
    July 18, 2019 11:52 AM EDT
    Gary said:

    Hi SocialEngineAddOns I'll be contacting today or tomorrow. Thanks Gary

     
    Hi Gary,

    Sure! You may either send an email or file a support ticket. 

    Thanks!

    • 177 posts
    July 18, 2019 3:33 PM EDT

    im getting error occurred when uploading the upgrade. 

     

    My upload limits are set higher than defaults so thats not an issue. 

    • Moderator
    • 3528 posts
    July 18, 2019 5:24 PM EDT

    Please don't post issues in the release thread. :) As for that, it only occurs when the license doesn't match the domain in your account. If it matches, you would need to get with our support as it's not a known issue other than local installs set up as localhost or if the domain doesn't match. If you need more help with that, please post a thread or please contact our support.

  • July 19, 2019 12:18 PM EDT

    i got a 503 error after upgrade where do i post it.

    • Moderator
    • 3528 posts
    July 19, 2019 12:52 PM EDT

    You would contact support. Or check for errors and third party experts whose products you use as it could be that. Alternately, you could open a thread under the SEPHP Help and Tips section but make sure you don't post private details. You would want to check your error log and post errors (removing private details). My own sites upgraded fine.