Community

Forums » 3rd Party Product Discussions

Problem for delete photos on Groups

    • 102 posts
    November 18, 2019 9:40 AM EST

    Hello,

    Impossible to delete photos on groups since 2 or 3 weeks.

    See Attachment

    Have you an idea ?

    Thanks in advance

    • Moderator
    • 3861 posts
    November 18, 2019 9:58 AM EST

    Please check that code in your error log. The codes are random numbers and letters so look for that one you see in your image and see what the error says. Also, always state what version of SEPHP you are using and whether it is the default plugin or a third party plugin.

    • 102 posts
    November 18, 2019 10:17 AM EST

    Thank you for this method

    Error: Call to a member function delete() on null in web/application/modules/Group/Model/DbTable/Photos.php:46
    Stack trace:
    #0 web/application/modules/Group/controllers/PhotoController.php(320): Group_Model_DbTable_Photos->deletePhoto(Object(Group_Model_Photo))
    #1 web/application/libraries/Zend/Controller/Action.php(516): Group_PhotoController->deleteAction()
    #2 web/application/libraries/Zend/Controller/Dispatcher/Standard.php(308): Zend_Controller_Action->dispatch('deleteAction')
    #3 web/application/libraries/Zend/Controller/Front.php(954): Zend_Controller_Dispatcher_Standard->dispatch(Object(Zend_Controller_Request_Http), Object(Zend_Controller_Response_Http))
    #4 web/application/modules/Core/Bootstrap.php(84): Zend_Controller_Front->dispatch()
    #5 web/application/libraries/Engine/Application.php(160): Core_Bootstrap->run()
    #6 web/application/index.php(223): Engine_Application->run()
    #7 web/boot.php(47): include('/var/www/client...')
    #8 web/index.php(24): Engine_Boot->boot()
    #9 {main}

    Thanks in advance

     

    • Moderator
    • 3861 posts
    November 19, 2019 5:14 AM EST

    I'm not having this on my test site. What version of SEPHP are you using? Are you using the default photo plugin or a third party plugin?

    • 102 posts
    November 19, 2019 5:16 AM EST

    We use third party plugin...  SEA Advanced Photo Album

    Thanks a lot

    • Moderator
    • 3861 posts
    November 19, 2019 5:17 AM EST

    I also tested at our demo https://demo.socialengine.com/ and it worked for me there. Can you please test at our demo? Also, if it breaks for you at our demo to, please put steps to reproduce it as the photo deleted for me.

    • Moderator
    • 3861 posts
    November 19, 2019 5:17 AM EST

    Oh ok. Please contact SEAO.

    • Moderator
    • 3861 posts
    November 19, 2019 5:17 AM EST

    Oh ok. Please contact SEAO.