Forums » SEPHP Help and Tips

Frorums work for me but for other user I get an error page

    • 138 posts
    December 18, 2019 2:23 PM EST

    I mean to say Forums and can't edit the subject of the post. It's one error after another for the last couple of weeks on my social engine site.

    I get this error from the forums page when I log in as other users besides Admin. IF I am admin it works fine. IF not I get this error.

    We're sorry!

    We are currently experiencing some technical issues. Please try again or report this to your site administrator using the....

     

    Administrator: Please check the error log in your admin panel for more information regarding this error.

     

    Error Code: 1c668e


    This post was edited by whatonearth at December 18, 2019 2:26 PM EST
    • Moderator
    • 4226 posts
    December 18, 2019 5:49 PM EST

    Error codes are random letters and numbers. Please check the error log and post the actual error in full (removing anything sensitive for site info). This will help to see what it goes to. The best way to get the full code is download the error log. Also, clear the log after you debug in order to avoid massive error logs.

    • Moderator
    • 4226 posts
    December 18, 2019 5:49 PM EST

    Also, check your user group permissions for the forums.

    • 138 posts
    December 18, 2019 6:48 PM EST

    The permissions look like they are set correctly. What other error. Where? You mean turn on debug mode?

    • Moderator
    • 4226 posts
    December 19, 2019 5:13 AM EST

    The error code you posted above. Please go to the error logs in admin panel and please find that code in the logs and copy/paste the actual error it goes to.

    • 138 posts
    December 19, 2019 10:32 AM EST
    Error Code: 1c668e<br>Core_Model_Item_Exception: No owner id defined in /home/user/public_html/application/modules/Core/Model/Item/Abstract.php:761<br>Stack trace:<br>#0 /home/user/public_html/application/modules/Core/Model/Item/Abstract.php(794): Core_Model_Item_Abstract->getOwner()<br>#1 /home/user/public_html/application/modules/Authorization/Model/DbTable/Allow.php(70): Core_Model_Item_Abstract->isOwner(Object(User_Model_User))<br>#2 /home/user/public_html/application/modules/Authorization/Api/Core.php(135): Authorization_Model_DbTable_Allow->isAllowed(Object(Forum_Model_Forum), Object(User_Model_User), 'view')<br>#3 /home/user/public_html/application/modules/Forum/controllers/IndexController.php(36): Authorization_Api_Core->isAllowed(Object(Forum_Model_Forum), Object(User_Model_User), 'view')<br>#4 /home/user/public_html/application/libraries/Zend/Controller/Action.php(516): Forum_IndexController->indexAction()<br>#5 /home/user/public_html/application/libraries/Zend/Controller/Dispatcher/Standard.php(308): Zend_Controller_Action->dispatch('indexAction')<br>#6 /home/user/public_html/application/libraries/Zend/Controller/Front.php(954): Zend_Controller_Dispatcher_Standard->dispatch(Object(Zend_Controller_Request_Http), Object(Zend_Controller_Response_Http))<br>#7 /home/user/public_html/application/modules/Core/Bootstrap.php(84): Zend_Controller_Front->dispatch()<br>#8 /home/user/public_html/application/libraries/Engine/Application.php(160): Core_Bootstrap->run()<br>#9 /home/user/public_html/application/index.php(223): Engine_Application->run()<br>#10 /home/user/public_html/boot.php(47): include('/home/networkin...')<br>#11 /home/user/public_html/index.php(24): Engine_Boot->boot()<br>#12 {main}<br>2019-12-18T19:23:24+00:00 CRIT (2): Zend_Locale_Exception: No date part in '' found. in /home/user/public_html/application/libraries/Zend/Locale/Format.php:913<br>Stack trace:<br>#0 /home/user/public_html/application/libraries/Zend/Locale/Format.php(1162): Zend_Locale_Format::_parseDate(false, Array)<br>#1 /home/user/public_html/application/libraries/Zend/Date.php(2641): Zend_Locale_Format::getDate(false, Array)<br>#2 /home/user/public_html/application/libraries/Zend/Date.php(1078): Zend_Date->_calculate('set', false, 'd MMM y HH:mm:s...', 'en_GB')<br>#3 /home/user/public_html/application/libraries/Zend/Date.php(197): Zend_Date->set(false, NULL, 'en_GB')<br>#4 /home/user/public_html/application/libraries/Engine/View/Helper/Locale.php(307): Zend_Date->__construct(false)<br>#5 /home/user/public_html/application/libraries/Engine/View/Helper/Locale.php(216): Engine_View_Helper_Locale->_checkDateTime('1982-31-05', Array)<br>#6 /home/user/public_html/application/modules/Fields/View/Helper/FieldBirthdate.php(29): Engine_View_Helper_Locale->toDate('1982-31-05', Array)<br>#7 /home/user/public_html/application/modules/Fields/View/Helper/FieldValueLoop.php(159): Fields_View_Helper_FieldBirthdate->fieldBirthdate(Object(User_Model_User), Object(Fields_Model_Meta), Object(Fields_Model_Value))<br>#8 /home/user/public_html/application/modules/Fields/View/Helper/FieldValueLoop.php(97): Fields_View_Helper_FieldValueLoop->getFieldValueString(Object(Fields_Model_Meta), Object(Fields_Model_Value), Object(User_Model_User), Object(Fields_Model_Map), Array)<br>#9 /home/user/public_html/application/libraries/Zend/View/Abstract.php(349): Fields_View_Helper_FieldValueLoop->fieldValueLoop(Object(User_Model_User), Array)<br>#10 /home/user/public_html/application/modules/User/widgets/profile-fields/index.tpl(16): Zend_View_Abstract->__call('fieldValueLoop', Array)<br>#11 /home/user/public_html/application/libraries/Zend/View.php(157): include('/home/networkin...')<br>#12 /home/user/public_html/application/libraries/Zend/View/Abstract.php(888): Zend_View->_run('/home/networkin...')<br>#13 /home/user/public_html/application/libraries/Engine/Content/Widget/Abstract.php(292): Zend_View_Abstract->render(NULL)<br>#14 /home/user/public_html/application/libraries/Engine/Content/Widget/Abstract.php(258): Engine_Content_Widget_Abstract->renderScript()<br>#15 /home/user/public_html/application/libraries/Engine/Content/Element/Widget.php(73): Engine_Content_Widget_Abstract->render('index')<br>#16 /home/user/public_html/application/libraries/Engine/Content/Element/Abstract.php(583): Engine_Content_Element_Widget->_render()<br>#17 /home/user/public_html/application/modules/Core/widgets/container-tabs/Controller.php(56): Engine_Content_Element_Abstract->render()<br>#18 /home/user/public_html/application/libraries/Engine/Content/Widget/Abstract.php(254): Core_Widget_ContainerTabsController->indexAction()<br>#19 /home/user/public_html/application/libraries/Engine/Content/Element/Widget.php(73): Engine_Content_Widget_Abstract->render('index')<br>#20 /home/user/public_html/application/libraries/Engine/Content/Element/Abstract.php(583): Engine_Content_Element_Widget->_render()<br>#21 /home/user/public_html/application/libraries/Engine/Content/Decorator/Children.php(31): Engine_Content_Element_Abstract->render()<br>#22 /home/user/public_html/application/libraries/Engine/Content/Element/Abstract.php(594): Engine_Content_Decorator_Children->render('')<br>#23 /home/user/public_html/application/libraries/Engine/Content/Decorator/Children.php(31): Engine_Content_Element_Abstract->render()<br>#24 /home/user/public_html/application/libraries/Engine/Content/Element/Abstract.php(594): Engine_Content_Decorator_Children->render('')<br>#25 /home/user/public_html/application/libraries/Engine/Content/Decorator/Children.php(31): Engine_Content_Element_Abstract->render()<br>#26 /home/user/public_html/application/libraries/Engine/Content/Element/Abstract.php(594): Engine_Content_Decorator_Children->render('')<br>#27 /home/user/public_html/application/libraries/Engine/Content.php(219): Engine_Content_Element_Abstract->render()<br>#28 /home/user/public_html/application/libraries/Engine/Content/Controller/Action/Helper/Content.php(136): Engine_Content->render('user_profile_in...')<br>#29 /home/user/public_html/application/libraries/Engine/Content/Controller/Action/Helper/Content.php(38): Engine_Content_Controller_Action_Helper_Content->render()<br>#30 /home/user/public_html/application/libraries/Zend/Controller/Action/HelperBroker.php(277): Engine_Content_Controller_Action_Helper_Content->postDispatch()<br>#31 /home/user/public_html/application/libraries/Zend/Controller/Action.php(527): Zend_Controller_Action_HelperBroker->notifyPostDispatch()<br>#32 /home/user/public_html/application/libraries/Zend/Controller/Dispatcher/Standard.php(308): Zend_Controller_Action->dispatch('indexAction')<br>#33 /home/user/public_html/application/libraries/Zend/Controller/Front.php(954): Zend_Controller_Dispatcher_Standard->dispatch(Object(Zend_Controller_Request_Http), Object(Zend_Controller_Response_Http))<br>#34 /home/user/public_html/application/modules/Core/Bootstrap.php(84): Zend_Controller_Front->dispatch()<br>#35 /home/user/public_html/application/libraries/Engine/Application.php(160): Core_Bootstrap->run()<br>#36 /home/user/public_html/application/index.php(223): Engine_Application->run()<br>#37 /home/user/public_html/boot.php(47): include('/home/networkin...')<br>#38 /home/user/public_html/index.php(24): Engine_Boot->boot()<br>#39 {main}
    This post was edited by Donna at December 20, 2019 6:07 AM EST
    • 138 posts
    December 19, 2019 10:33 AM EST

    Does that work?

    • Moderator
    • 4226 posts
    December 20, 2019 6:08 AM EST

    No it didn't and I can't fix it. Please use the icon to the right of the smiley icon as per the posted instructions as that is the code wrap and will wrap it properly.I cannot read the error as it's all mashed into one line. 


    This post was edited by Donna at December 20, 2019 6:08 AM EST
    • 138 posts
    December 20, 2019 11:04 AM EST
    Error Code: 1c668e Core_Model_Item_Exception: No owner id defined in /home/user/public_html/application/modules/Core/Model/Item/Abstract.php:761 Stack trace: #0 /home/user/public_html/application/modules/Core/Model/Item/Abstract.php(794): Core_Model_Item_Abstract->getOwner() #1 /home/user/public_html/application/modules/Authorization/Model/DbTable/Allow.php(70): Core_Model_Item_Abstract->isOwner(Object(User_Model_User)) #2 /home/user/public_html/application/modules/Authorization/Api/Core.php(135): Authorization_Model_DbTable_Allow->isAllowed(Object(Forum_Model_Forum), Object(User_Model_User), 'view') #3 /home/user/public_html/application/modules/Forum/controllers/IndexController.php(36): Authorization_Api_Core->isAllowed(Object(Forum_Model_Forum), Object(User_Model_User), 'view') #4 /home/user/public_html/application/libraries/Zend/Controller/Action.php(516): Forum_IndexController->indexAction() #5 /home/user/public_html/application/libraries/Zend/Controller/Dispatcher/Standard.php(308): Zend_Controller_Action->dispatch('indexAction') #6 /home/user/public_html/application/libraries/Zend/Controller/Front.php(954): Zend_Controller_Dispatcher_Standard->dispatch(Object(Zend_Controller_Request_Http), Object(Zend_Controller_Response_Http)) #7 /home/user/public_html/application/modules/Core/Bootstrap.php(84): Zend_Controller_Front->dispatch() #8 /home/user/public_html/application/libraries/Engine/Application.php(160): Core_Bootstrap->run() #9 /home/user/public_html/application/index.php(223): Engine_Application->run() #10 /home/user/public_html/boot.php(47): include('/home/networkin...') #11 /home/user/public_html/index.php(24): Engine_Boot->boot() #12 {main} 2019-12-18T19:23:24+00:00 CRIT (2): Zend_Locale_Exception: No date part in '' found. in /home/user/public_html/application/libraries/Zend/Locale/Format.php:913 Stack trace: #0 /home/user/public_html/application/libraries/Zend/Locale/Format.php(1162): Zend_Locale_Format::_parseDate(false, Array) #1 /home/user/public_html/application/libraries/Zend/Date.php(2641): Zend_Locale_Format::getDate(false, Array) #2 /home/user/public_html/application/libraries/Zend/Date.php(1078): Zend_Date->_calculate('set', false, 'd MMM y HH:mm:s...', 'en_GB') #3 /home/user/public_html/application/libraries/Zend/Date.php(197): Zend_Date->set(false, NULL, 'en_GB') #4 /home/user/public_html/application/libraries/Engine/View/Helper/Locale.php(307): Zend_Date->__construct(false) #5 /home/user/public_html/application/libraries/Engine/View/Helper/Locale.php(216): Engine_View_Helper_Locale->_checkDateTime('1982-31-05', Array) #6 /home/user/public_html/application/modules/Fields/View/Helper/FieldBirthdate.php(29): Engine_View_Helper_Locale->toDate('1982-31-05', Array) #7 /home/user/public_html/application/modules/Fields/View/Helper/FieldValueLoop.php(159): Fields_View_Helper_FieldBirthdate->fieldBirthdate(Object(User_Model_User), Object(Fields_Model_Meta), Object(Fields_Model_Value)) #8 /home/user/public_html/application/modules/Fields/View/Helper/FieldValueLoop.php(97): Fields_View_Helper_FieldValueLoop->getFieldValueString(Object(Fields_Model_Meta), Object(Fields_Model_Value), Object(User_Model_User), Object(Fields_Model_Map), Array) #9 /home/user/public_html/application/libraries/Zend/View/Abstract.php(349): Fields_View_Helper_FieldValueLoop->fieldValueLoop(Object(User_Model_User), Array) #10 /home/user/public_html/application/modules/User/widgets/profile-fields/index.tpl(16): Zend_View_Abstract->__call('fieldValueLoop', Array) #11 /home/user/public_html/application/libraries/Zend/View.php(157): include('/home/networkin...') #12 /home/user/public_html/application/libraries/Zend/View/Abstract.php(888): Zend_View->_run('/home/networkin...') #13 /home/user/public_html/application/libraries/Engine/Content/Widget/Abstract.php(292): Zend_View_Abstract->render(NULL) #14 /home/user/public_html/application/libraries/Engine/Content/Widget/Abstract.php(258): Engine_Content_Widget_Abstract->renderScript() #15 /home/user/public_html/application/libraries/Engine/Content/Element/Widget.php(73): Engine_Content_Widget_Abstract->render('index') #16 /home/user/public_html/application/libraries/Engine/Content/Element/Abstract.php(583): Engine_Content_Element_Widget->_render() #17 /home/user/public_html/application/modules/Core/widgets/container-tabs/Controller.php(56): Engine_Content_Element_Abstract->render() #18 /home/user/public_html/application/libraries/Engine/Content/Widget/Abstract.php(254): Core_Widget_ContainerTabsController->indexAction() #19 /home/user/public_html/application/libraries/Engine/Content/Element/Widget.php(73): Engine_Content_Widget_Abstract->render('index') #20 /home/user/public_html/application/libraries/Engine/Content/Element/Abstract.php(583): Engine_Content_Element_Widget->_render() #21 /home/user/public_html/application/libraries/Engine/Content/Decorator/Children.php(31): Engine_Content_Element_Abstract->render() #22 /home/user/public_html/application/libraries/Engine/Content/Element/Abstract.php(594): Engine_Content_Decorator_Children->render('') #23 /home/user/public_html/application/libraries/Engine/Content/Decorator/Children.php(31): Engine_Content_Element_Abstract->render() #24 /home/user/public_html/application/libraries/Engine/Content/Element/Abstract.php(594): Engine_Content_Decorator_Children->render('') #25 /home/user/public_html/application/libraries/Engine/Content/Decorator/Children.php(31): Engine_Content_Element_Abstract->render() #26 /home/user/public_html/application/libraries/Engine/Content/Element/Abstract.php(594): Engine_Content_Decorator_Children->render('') #27 /home/user/public_html/application/libraries/Engine/Content.php(219): Engine_Content_Element_Abstract->render() #28 /home/user/public_html/application/libraries/Engine/Content/Controller/Action/Helper/Content.php(136): Engine_Content->render('user_profile_in...') #29 /home/user/public_html/application/libraries/Engine/Content/Controller/Action/Helper/Content.php(38): Engine_Content_Controller_Action_Helper_Content->render() #30 /home/user/public_html/application/libraries/Zend/Controller/Action/HelperBroker.php(277): Engine_Content_Controller_Action_Helper_Content->postDispatch() #31 /home/user/public_html/application/libraries/Zend/Controller/Action.php(527): Zend_Controller_Action_HelperBroker->notifyPostDispatch() #32 /home/user/public_html/application/libraries/Zend/Controller/Dispatcher/Standard.php(308): Zend_Controller_Action->dispatch('indexAction') #33 /home/user/public_html/application/libraries/Zend/Controller/Front.php(954): Zend_Controller_Dispatcher_Standard->dispatch(Object(Zend_Controller_Request_Http), Object(Zend_Controller_Response_Http)) #34 /home/user/public_html/application/modules/Core/Bootstrap.php(84): Zend_Controller_Front->dispatch() #35 /home/user/public_html/application/libraries/Engine/Application.php(160): Core_Bootstrap->run() #36 /home/user/public_html/application/index.php(223): Engine_Application->run() #37 /home/user/public_html/boot.php(47): include('/home/networkin...') #38 /home/user/public_html/index.php(24): Engine_Boot->boot() #39 {main}
    • Moderator
    • 4226 posts
    December 20, 2019 11:47 AM EST

    Thank you! much better.

    The first one is for the forum and is showing that the owner id is missing. Looks like it might be missing perms maybe. Try this. Go in your admin to the forum plugin and for every member level, set the permission again and save it. Clear cache and test as one of those users. If it works, yay! If not, you may want to try an upgrade of the forum plugin again. I may be wrong about what is going on but that's the first thought.

    The second one is not for the forum. It's for the user birthdate it looks like. Someone with a birthdate of 1982-31-05 and in a tabbed container maybe? Check third party widgets for that as perhaps you have a birthday widget left over from something removed. I think it's that.

    • 138 posts
    December 20, 2019 5:17 PM EST

    I reinstalled the core and the forums and I re-saved all the permission settings and logged on as one of the users and got an error and immediately copied the error message. Looks like I am not the only one getting this error because even though I went to the error log in less than a minute I saw other forums looking errors:

     

    #37 {main} 2019-12-20T16:09:40+00:00 CRIT (2): Error Code: b3e86d Forum_Model_Exception: Cannot have a forum without a category in /home/user/public_html/application/modules/Forum/Model/Forum.php:99 Stack trace: #0 /home/user/public_html/application/libraries/Zend/Db/Table/Row/Abstract.php(525): Forum_Model_Forum->_update() #1 /home/user/public_html/application/libraries/Zend/Db/Table/Row/Abstract.php(440): Zend_Db_Table_Row_Abstract->_doUpdate() #2 /home/user/public_html/application/modules/Forum/controllers/ForumController.php(52): Zend_Db_Table_Row_Abstract->save() #3 /home/user/public_html/application/libraries/Zend/Controller/Action.php(516): Forum_ForumController->viewAction() #4 /home/user/public_html/application/libraries/Zend/Controller/Dispatcher/Standard.php(308): Zend_Controller_Action->dispatch('viewAction') #5 /home/user/public_html/application/libraries/Zend/Controller/Front.php(954): Zend_Controller_Dispatcher_Standard->dispatch(Object(Zend_Controller_Request_Http), Object(Zend_Controller_Response_Http)) #6 /home/user/public_html/application/modules/Core/Bootstrap.php(84): Zend_Controller_Front->dispatch() #7 /home/user/public_html/application/libraries/Engine/Application.php(160): Core_Bootstrap->run() #8 /home/user/public_html/application/index.php(223): Engine_Application->run() #9 /home/user/public_html/boot.php(47): include('/home/networkin...') #10 /home/user/public_html/index.php(24): Engine_Boot->boot() #11 {main} 2019-12-20T20:39:54+00:00 CRIT (2): Error Code: d00e26 Forum_Model_Exception: Cannot have a forum without a category in /home/user/public_html/application/modules/Forum/Model/Forum.php:99 Stack trace: #0 /home/user/public_html/application/libraries/Zend/Db/Table/Row/Abstract.php(525): Forum_Model_Forum->_update() #1 /home/user/public_html/application/libraries/Zend/Db/Table/Row/Abstract.php(440): Zend_Db_Table_Row_Abstract->_doUpdate() #2 /home/user/public_html/application/modules/Forum/controllers/ForumController.php(52): Zend_Db_Table_Row_Abstract->save() #3 /home/user/public_html/application/libraries/Zend/Controller/Action.php(516): Forum_ForumController->viewAction() #4 /home/user/public_html/application/libraries/Zend/Controller/Dispatcher/Standard.php(308): Zend_Controller_Action->dispatch('viewAction') #5 /home/user/public_html/application/libraries/Zend/Controller/Front.php(954): Zend_Controller_Dispatcher_Standard->dispatch(Object(Zend_Controller_Request_Http), Object(Zend_Controller_Response_Http)) #6 /home/user/public_html/application/modules/Core/Bootstrap.php(84): Zend_Controller_Front->dispatch() #7 /home/user/public_html/application/libraries/Engine/Application.php(160): Core_Bootstrap->run() #8 /home/user/public_html/application/index.php(223): Engine_Application->run() #9 /home/user/public_html/boot.php(47): include('/home/networkin...') #10 /home/user/public_html/index.php(24): Engine_Boot->boot() #11 {main} 2019-12-20T22:13:16+00:00 CRIT (2): Error Code: 01698c
    This post was edited by whatonearth at December 20, 2019 5:18 PM EST
    • Moderator
    • 4226 posts
    December 21, 2019 5:51 AM EST

    Well you're in luck on that one. I had that on my author site after importing as fox has different setups and allows for no category forum sections. Check to ensure that your forums are set up properly with the structure SE needs. Your main category is basically a "header" and under that it should have a "subcategory" that is where the posts should be. No posts should be on their own without that "subcategory" .

    • 138 posts
    December 26, 2019 9:29 AM EST

    I don't know that is the problem. I checked an all my forums are under a category. I will delete and start from scratch. I will want to find a way to set up a new fresh install and import all users to the new version without spending a bunch of money for an "expert"