Forums » SEPHP Help and Tips

Cannot update files...

    • 6 posts
    January 23, 2020 1:04 PM EST

    I have run into an issue, I am trying to update my version to 4.10.5 and in the Run, pre-install check it shows a red flag under the requires MySQL 5.7, my host uses MySQL Version 10.2.25-MariaDB-log ... I assume since they use a different version of the SQL (10.2.25-MariaDB-log) maybe it will not install because it thinks that their version does not equal the 5.7...I have never had a problem installing updates prior to now... is there a way around this issue?

    • 38 posts
    January 23, 2020 4:37 PM EST
    As of version 4.10.5, mysql 5.7 or later is required. Mariadb is a fork of mysql therefore you will either need to completely change your server's database to mysql
    • Moderator
    • 5057 posts
    January 24, 2020 6:14 AM EST

    That is correct @ themrt , as SEPHP does not support MariaDB. Thank you for your help :)

    • 6 posts
    February 6, 2020 12:45 PM EST

    I think my hosting provider has been running Mariadb for the last few years and it has worked, they are now running Mariadb 10.2 and are not planning for an upgrade. I am speaking with their sister company who is running Mariadb 10.3 about transferring my account over to them. I had this post from another member that I reached out to and this was her reply: Elshara Silverheart My best advice for you is to upgrade to 10.3 or 10.4. I think 10.2 Mariadb is too out of date for social engine. I am running 10.3 and it works.

    So I am not sure how to approach this now. Did SocialEngine use to work with Mariadb?

    • Moderator
    • 5057 posts
    February 6, 2020 2:15 PM EST

    No, it has never supported Mariadb but we do have clients using it. There are some threads in which some may have provided tips. I suggest trying a search in our community to see if any of the threads will help.

    • 6 posts
    February 6, 2020 8:18 PM EST

    Thank you Donna