Forums » 3rd Party Product Discussions

formatting code in email notifications

    • 13 posts
    January 29, 2020 6:08 PM EST

    I have been facing for a long time an issue with email notifications. I am using an email template plugin from SocialApps.tech (formerly SocialEngineAddOns). When a message is sent to a group, again using their group plugin, it uses TinyMCE and an email notification is sent. The issue is that the formatting code are showing in the email notification as in the screen capture below.

    At some point SocialApps fixed it by changing code as following in what looks like SocialEngine code:

     

    This change worked for a while but reapplying this change again last month disn't do it.

    They indicated: "I would request you to contact Social Engine team once and let us know their response once. Because this issue is with the message composer which has been provided by Social engine team itself."

    I didn't see much about Rich Text Format for email notifications, I even installed a SE PHP test site to find out more about it without success, althoug formatting is allowed on internal SE messages but not used in email notifcations. On the other side, SEAO allows these in email notifications, but they say that everytime SE makes an upgrade, their changes are lost.

    I am between a rock and a hard place. Please help me getting this resolved. You might have to move this to bug report. Some others might say "if you can't fix it, feature it..." this was one of my standard line when I used to be a product manager in the telecom industry.

    Thanks,

     

     


    This post was edited by Donna at January 29, 2020 6:19 PM EST
    • Moderator
    • 4802 posts
    January 29, 2020 6:23 PM EST

    our forum rules mention not to post code without using the code tag which is the icon next to the smiley. Please add your code back with the code tags included. As you are modifying source code, it will be removed on upgrades. We recommend not modifying source codes and doing changes in your own plugin or their plugin instead of the core. Otherwise, you will need to reapply any changes done when upgrading and maybe even upgrade your code too at the time. Are you saying that you also see the issue on a clean development site (set up per the SocialEngine terms)?