Forums » 3rd Party Product Discussions

Lots of "Call to a member function temporary() on null"

    • 33 posts
    February 12, 2020 6:43 PM EST

     


    So when i checked my error log, in the log I noticed a lot of repeated errors as shown below

    2020-02-12T22:53:02+00:00 ERR (3): Error Code: 012325 Error: Call to a member function temporary() on null in /var/www/vhosts/xxxx/httpdocs/application/modules/Advancedactivity/Plugin/Core.php:49 Stack trace: #0 /var/www/vhosts/xxxx/httpdocs/application/libraries/Engine/Hooks/Dispatcher.php(224): Advancedactivity_Plugin_Core->onAlbumPhotoUpdateAfter(Object(Engine_Hooks_Event)) #1 /var/www/vhosts/xxxx/httpdocs/application/modules/Core/Model/Item/Abstract.php(554): Engine_Hooks_Dispatcher->callEvent('onAlbumPhotoUpd...', Object(Engine_Hooks_Event)) #2 /var/www/vhosts/xxxx/httpdocs/application/libraries/Zend/Db/Table/Row/Abstract.php(569): Core_Model_Item_Abstract->_postUpdate() #3 /var/www/vhosts/xxxx/httpdocs/application/libraries/Zend/Db/Table/Row/Abstract.php(440): Zend_Db_Table_Row_Abstract->_doUpdate() #4 /var/www/vhosts/xxxx/httpdocs/application/modules/Album/controllers/PhotoController.php(50): Zend_Db_Table_Row_Abstract->save() #5 /var/www/vhosts/xxxx/httpdocs/application/libraries/Zend/Controller/Action.php(516): Album_PhotoController->viewAction() #6 /var/www/vhosts/xxxx/httpdocs/application/libraries/Zend/Controller/Dispatcher/Standard.php(308): Zend_Controller_Action->dispatch('viewAction') #7 /var/www/vhosts/xxxx/httpdocs/application/libraries/Zend/Controller/Front.php(954): Zend_Controller_Dispatcher_Standard->dispatch(Object(Zend_Controller_Request_Http), Object(Zend_Controller_Response_Http)) #8 /var/www/vhosts/xxxx/httpdocs/application/modules/Core/Bootstrap.php(86): Zend_Controller_Front->dispatch() #9 /var/www/vhosts/xxxx/httpdocs/application/libraries/Engine/Application.php(160): Core_Bootstrap->run() #10 /var/www/vhosts/xxxx/httpdocs/application/index.php(223): Engine_Application->run() #11 /var/www/vhosts/xxxx/httpdocs/boot.php(47): include('/var/www/vhosts...') #12 /var/www/vhosts/xxxx/httpdocs/index.php(24): Engine_Boot->boot() #13 {main}

     

     

     

    • Moderator
    • 4802 posts
    February 13, 2020 5:41 AM EST

    Did you contact the third party developer of that advanced activity plugin? Note that no plugins that I know of have been upgraded to v5 if you are using v5.

    • 277 posts
    February 14, 2020 2:49 AM EST

    Hi @themrt,

     

    Kindly share the steps to reproduce the issue. 

    We would also further require your website details in order to debug it. So, you can contact us at support@socialapps.tech and we will be happy to assist you. 
    If needed, we will make the changes in our plugin as well and upgrade it. 

     

    Regards, 

    SocialApps.tech Team

     


    This post was edited by SocialApps at February 14, 2020 2:50 AM EST