Forums » 3rd Party Product Discussions

I NEED GUIDANCE - Working on local

    • 26 posts
    March 18, 2020 11:00 PM EDT

    Hello community,

    I'm frustrated with something that could be "nothing" but as you know, some plugins from third parties are now developed correctly and were not properly tested before offering to customers. After investing more than US$1,500 with this third party company and I'm still stuck trying to configure plugins.

     

    Since this third company DO NOT provide service at the local server level even we expended a lot of money, we had to configure all plugins in the server. However, due to the number of bugs we are finding in their plugins, we need to work on local to continue fixing issues. We informed them our plan, we cloned, downloaded and installed everything on local, almost everything is working as mirror of our server, but some features as header and activity feeds are not visible, we tried everything unsuccessfully.

     

    Our Plan B is to have two people working on local because we need to launch as soon as possible, but with this issue is hard to work, the third party company is not helping as expected.

    We are using several plugins from SocialNetworking Solutions including the Responsive A to Z theme. The main problem is that HEADER is not shown, therefore, a lot of features are missing, we had to uninstall other plugin in order to fix the activity feeds, it does not make sense, we have a clone and did the right thing, why some features/plugins are not working properly, and If the vendor knows why not say how to fix it, I am frustrated. 

     


    This post was edited by Angel at March 19, 2020 12:53 PM EDT
    • Moderator
    • 4802 posts
    March 19, 2020 5:38 AM EDT

    With development mode off, do you see any difference? Same question but with development mode on.

    What is the PHP version on local?

    What environment (mac or winblows)? Since SEPHP isn't set for winblows, it could even be something from that but without knowing more, it's hard to help much.

    I use Mamp Pro on my mac and winblows as it sets up the local better than xampp from what I've experienced. Make sure you do not have any FCGI enabled, have PHP 7.2.x and have mysql 5.7. Make sure the theme is compatible with your SEPHP version which you hadn't mentioned. Are you on current v5? If you are on a version below v4.10, also make sure you are using the correct PHP as I do not recall which version we upped the requirement from 5.6 to 7 but older versions do not support above PHP 5.6.


    This post was edited by Donna at March 19, 2020 5:38 AM EDT
    • 287 posts
    March 19, 2020 1:07 PM EDT

    Could this be a dependency issue, have you installed all the same php mods? 

     

    What errors show in the browser on the loading of the page? ( Ctrl + Shift + J ) in chrome

    • 26 posts
    March 19, 2020 1:35 PM EDT

    Hello Donna,

    I'm going to try with Mamp Pro, I will review the versions that you mentioned. We tried with/without development mode on too. I forgot to mention that it works perfectly if we disabled all plugins from third party, I mean HEADER and ACTIVITY FEEDS for SE (without plugins) works fine. BTW, I really appreciate your previous comment. We use Windows, now we are going to try on Mac to see how it goes. Best Regards! Angel