Forums » SEPHP Help and Tips

Getting this error when I try to delete a forum

    • 203 posts
    May 1, 2020 10:19 AM EDT

    I get this when I try to delete a forum in the Admin section for managing forums.

     

    We are currently experiencing some technical issues. Please try again or report this to your site administrator using the contact form.

    Administrator: Please check the error log in your admin panel for more information regarding this error.

    Error Code: 7c873d

    Error Code: 7c873d
    Zend_Db_Statement_Mysqli_Exception: Mysqli statement execute error : BIGINT UNSIGNED value is out of range in '(`networks_newsite`.`engine4_forum_categories`.`forum_count` - 1)' in /home/networks/public_html/application/libraries/Zend/Db/Statement/Mysqli.php:214
    Stack trace:
    #0 /home/networks/public_html/application/libraries/Zend/Db/Statement.php(303): Zend_Db_Statement_Mysqli->_execute(Array)
    #1 /home/networks/public_html/application/libraries/Zend/Db/Adapter/Abstract.php(480): Zend_Db_Statement->execute(Array)
    #2 /home/networks/public_html/application/libraries/Zend/Db/Adapter/Abstract.php(635): Zend_Db_Adapter_Abstract->query('UPDATE `engine4...', Array)
    #3 /home/networks/public_html/application/libraries/Zend/Db/Table/Abstract.php(1133): Zend_Db_Adapter_Abstract->update('engine4_forum_c...', Array, '(`engine4_forum...')
    #4 /home/networks/public_html/application/libraries/Engine/Db/Table.php(158): Zend_Db_Table_Abstract->update(Array, Array)
    #5 /home/networks/public_html/application/libraries/Zend/Db/Table/Row/Abstract.php(561): Engine_Db_Table->update(Array, Array)
    #6 /home/networks/public_html/application/libraries/Zend/Db/Table/Row/Abstract.php(440): Zend_Db_Table_Row_Abstract->_doUpdate()
    #7 /home/networks/public_html/application/modules/Forum/Model/Forum.php(110): Zend_Db_Table_Row_Abstract->save()
    #8 /home/networks/public_html/application/libraries/Zend/Db/Table/Row/Abstract.php(610): Forum_Model_Forum->_delete()
    #9 /home/networks/public_html/application/modules/Forum/controllers/AdminManageController.php(408): Zend_Db_Table_Row_Abstract->delete()
    #10 /home/networks/public_html/application/libraries/Zend/Controller/Action.php(516): Forum_AdminManageController->deleteForumAction()
    #11 /home/networks/public_html/application/libraries/Zend/Controller/Dispatcher/Standard.php(308): Zend_Controller_Action->dispatch('deleteForumActi...')
    #12 /home/networks/public_html/application/libraries/Zend/Controller/Front.php(954): Zend_Controller_Dispatcher_Standard->dispatch(Object(Zend_Controller_Request_Http), Object(Zend_Controller_Response_Http))
    #13 /home/networks/public_html/application/modules/Core/Bootstrap.php(86): Zend_Controller_Front->dispatch()
    #14 /home/networks/public_html/application/libraries/Engine/Application.php(160): Core_Bootstrap->run()
    #15 /home/networks/public_html/application/index.php(223): Engine_Application->run()
    #16 /home/networks/public_html/boot.php(47): include('/home/networks/...')
    #17 /home/networks/public_html/index.php(24): Engine_Boot->boot()
    #18 {main}


    This post was edited by whatonearth at May 1, 2020 10:20 AM EDT
    • Moderator
    • 5069 posts
    May 2, 2020 5:06 AM EDT

    What version of PHP on the server? Are you using Mariadb or Mysql? What version of that are you using? I didn't see an error like this when I deleted one on a client site the other day but I'll test on my staging.