Forums » SEPHP Feature Requests

[A]S3 add Mumbai

  • May 13, 2020 10:27 AM EDT

    Receiving exception when uploading files with S3 as default storage

    Whereas it is working very fine in aws s3 cli.

    Error Code: 126599
    Storage_Service_Exception: Unable to store file. in /var/www/html/application/modules/Storage/Service/S3.php:126
    Stack trace:
    #0 /var/www/html/application/modules/Storage/Model/File.php(133): Storage_Service_S3->store(Object(Storage_Model_File), '/var/www/html/t...')
    #1 /var/www/html/application/modules/Storage/Model/DbTable/Files.php(131): Storage_Model_File->store('/var/www/html/t...')
    #2 /var/www/html/application/modules/Sesletteravatar/Api/Core.php(81): Storage_Model_DbTable_Files->createFile('/var/www/html/t...', Array)
    #3 /var/www/html/application/modules/Sesletteravatar/Plugin/Core.php(42): Sesletteravatar_Api_Core->letterAvatar(Object(User_Model_User), 'recruiter1 talb...')
    #4 /var/www/html/application/libraries/Engine/Hooks/Dispatcher.php(224): Sesletteravatar_Plugin_Core->onUserUpdateAfter(Object(Engine_Hooks_Event))
    #5 /var/www/html/application/modules/Core/Model/Item/Abstract.php(554): Engine_Hooks_Dispatcher->callEvent('onUserUpdateAft...', Object(Engine_Hooks_Event))
    #6 /var/www/html/application/libraries/Zend/Db/Table/Row/Abstract.php(569): Core_Model_Item_Abstract->_postUpdate()
    #7 /var/www/html/application/libraries/Zend/Db/Table/Row/Abstract.php(440): Zend_Db_Table_Row_Abstract->_doUpdate()
    #8 /var/www/html/application/modules/Sitesubscription/Plugin/Signup/Fields.php(293): Zend_Db_Table_Row_Abstract->save()
    #9 /var/www/html/application/modules/Core/Controller/Action/Helper/FormSequence.php(193): Sitesubscription_Plugin_Signup_Fields->onProcess()
    #10 /var/www/html/application/modules/Core/Controller/Action/Helper/FormSequence.php(45): Core_Controller_Action_Helper_FormSequence->doProcess()
    #11 /var/www/html/application/libraries/Zend/Controller/Action/HelperBroker.php(328): Core_Controller_Action_Helper_FormSequence->direct()
    #12 /var/www/html/application/modules/User/controllers/SignupController.php(59): Zend_Controller_Action_HelperBroker->__call('formSequence', Array)
    #13 /var/www/html/application/libraries/Zend/Controller/Action.php(516): User_SignupController->indexAction()
    #14 /var/www/html/application/libraries/Zend/Controller/Dispatcher/Standard.php(308): Zend_Controller_Action->dispatch('indexAction')
    #15 /var/www/html/application/libraries/Zend/Controller/Front.php(954): Zend_Controller_Dispatcher_Standard->dispatch(Object(Zend_Controller_Request_Http), Object(Zend_Controller_Response_Http))
    #16 /var/www/html/application/modules/Core/Bootstrap.php(84): Zend_Controller_Front->dispatch()
    #17 /var/www/html/application/libraries/Engine/Application.php(160): Core_Bootstrap->run()
    #18 /var/www/html/application/index.php(223): Engine_Application->run()
    #19 /var/www/html/boot.php(47): include('/var/www/html/a...')
    #20 /var/www/html/index.php(24): Engine_Boot->boot()
    #21 {main}

    • Moderator
    • 4676 posts
    May 13, 2020 12:29 PM EDT

    You hadn't posted per the stickied bug guidelines. Also, it looks like you are using a third party plugin. Have you checked with the developer to see if there's an issue with the plugin since it shows in your error?

    • Moderator
    • 4676 posts
    May 13, 2020 12:31 PM EDT

    I checked as we use S3 here and there are no errors here for this. Please check with the third party expert for the plugin that shows in the error log in case there is some issue from that end. Also, please ensure you are using current SEPHP version.

  • May 14, 2020 6:15 AM EDT

    Hi Donna, I am the developer and also architect of this. I am using core storage module to store into my s3 bucket but I am getting the above error for Mumbai region. Whereas for others it just finishes without error but files are not moved. I am using SE 4.10.5

  • May 14, 2020 6:15 AM EDT
    Donna said:

    You hadn't posted per the stickied bug guidelines. Also, it looks like you are using a third party plugin. Have you checked with the developer to see if there's an issue with the plugin since it shows in your error?

    Sorry will stick to it next time.

    • Moderator
    • 4676 posts
    May 14, 2020 6:46 AM EDT

    We require bug reports to be on current version or supported version. 4.10.5 is not supported. However, I am not sure that region is in our list for regions so have you tried a different region? I'll ask our dev team to check on the regions we support atm. We do have improvements coming for that too.

  • May 14, 2020 6:57 AM EDT

    Thanks donna that would be very helpful.

    • Moderator
    • 4676 posts
    May 14, 2020 8:10 AM EDT

    Our team checked and Mumbai is not supported yet but we will have improvements. I'll move this from bugs to features and put it as accepted.

  • May 14, 2020 8:28 AM EDT

    great donna thanks very much.

    But i ll try to debug issues for other regions as its not working for singapore also

  • May 15, 2020 2:56 AM EDT

    Hi Donna Reinstalling removed this issue.

    • Moderator
    • 4676 posts
    May 15, 2020 4:41 AM EDT

    Great! So the Singapore works. Did the Mumbai work too?