Forums » SEPHP Help and Tips

Video conversion failed. Please try uploading again.

    • 27 posts
    June 21, 2020 7:33 AM EDT



    How do i fix this problem

    • 132 posts
    June 21, 2020 7:51 AM EDT

    Essentially, you need to make ffmpeg executable e.g. chmod +x /path_to_ffmpeg/ffmpeg.

    • 27 posts
    June 21, 2020 8:01 AM EDT

    sorry im newbie to this where can i do this ?  i know what "chmod" is that can be found in filezilla when you give permission but what does the rest means? " +x /path_to_ffmpeg/ffmpeg"


    This post was edited by S1nd0 at June 21, 2020 8:14 AM EDT
    • 132 posts
    June 21, 2020 8:56 AM EDT

    You can find your path to ffmpeg in your Admin Panel under Admin Panel > Plugins > Video > Global Settings.

     

    Usually it's /usr/bin/ffmpeg, but if you are on shared hosting it might be elsewhere.

     

    You need to make the file executable.

     

     

    • 27 posts
    June 21, 2020 9:24 AM EDT



    its already setup :/

    • Moderator
    • 4830 posts
    June 21, 2020 1:19 PM EDT

    Your host should be able to assist you with ffmpeg issues. Try them and see if they can help. 

    • 132 posts
    June 21, 2020 1:51 PM EDT

     Are you on shared hosting? If so, do as Donna says and contact your host.

     

    Looking at the ffmpeg version information, you are using a downloaded build of ffmpeg. I suspect that you have downloaded your own copy of ffmpeg and uploaded it to your site. For external tasks, php may be running as another user. If you are able to access the ffmpeg file through filezilla, right click it and ensure that EVERYONE can read and execute it. I cannot remember what the filezilla interface looks like, but as you mentioned you could see the chmod option. If you need a number, 755 is the appropriate one.

    • 27 posts
    June 21, 2020 3:33 PM EDT
    abuk said:

     Are you on shared hosting? If so, do as Donna says and contact your host.

     

    Looking at the ffmpeg version information, you are using a downloaded build of ffmpeg. I suspect that you have downloaded your own copy of ffmpeg and uploaded it to your site. For external tasks, php may be running as another user. If you are able to access the ffmpeg file through filezilla, right click it and ensure that EVERYONE can read and execute it. I cannot remember what the filezilla interface looks like, but as you mentioned you could see the chmod option. If you need a number, 755 is the appropriate one.

    my host provider is aws but they answer like 24 hours after i have created af ticket and charge me over 29$ for faster support .. all this should have been setup when the server was created(as i paid someone to do)  ... i have tried looking into the ffmpeg folder and it cant be changed to 755 :/

    • 132 posts
    June 21, 2020 4:41 PM EDT

    Where is ffmpeg installed?

    What opertting system are you using?

    Do you have root shell access to the server?

    If not root, do you have any shell access to the server?

    • 27 posts
    June 21, 2020 4:51 PM EDT
    abuk said:

    Where is ffmpeg installed?

    What opertting system are you using?

    Do you have root shell access to the server?

    If not root, do you have any shell access to the server?

    AWS lightsail and the FFMPEG is installed at ffmpeg/ffmpeg
    im using windows 10 filezilla
    i have root access i think

    • 132 posts
    June 21, 2020 6:09 PM EDT

    If you have root access, the best thing I can recommend to do is to install the ffmpeg package included with your operating system, either

    apt-get install ffmpeg

    yum install ffmpeg

    and then use that installation for ffmpeg, as the package would set it up with the necessary permissions.

     

    It would seem that the web server php user can use ffmpeg otherwise the text boxes on your 'Video Utilities' section would not have text in them as it needs to execute ffmpeg in order to generate the text. Can you upload a screenshot of your ffmpeg directory, in particular the permissions and owner/group of ffmpeg?

     

    You won't get another reply from me for about 15 hours or so.


    This post was edited by abuk at June 21, 2020 6:10 PM EDT
    • 27 posts
    June 21, 2020 10:29 PM EDT
    abuk said:

    If you have root access, the best thing I can recommend to do is to install the ffmpeg package included with your operating system, either

    apt-get install ffmpeg

    yum install ffmpeg

    and then use that installation for ffmpeg, as the package would set it up with the necessary permissions.

     

    It would seem that the web server php user can use ffmpeg otherwise the text boxes on your 'Video Utilities' section would not have text in them as it needs to execute ffmpeg in order to generate the text. Can you upload a screenshot of your ffmpeg directory, in particular the permissions and owner/group of ffmpeg?

     

    You won't get another reply from me for about 15 hours or so.


     

    permission is  set to 777

    • 132 posts
    June 22, 2020 5:20 AM EDT

    Observations:

    1. You must have access to the root account, as all your site files are owned by it.
    2. Having web site files owned and operated by the root account is generally a bad idea.
    3. ffMpeg is owned and group-owned by a differed user / group to the rest of your site, but as it is world-executable this shouldn't be a problem.
    4. The ffMpeg folder is owned by a different usergroup to the ffMpeg executable AND the rest of your site, which shouldn't be a problem, but I can't see why it's necessary.
    5. The SocialEngine code that generates the error is at line 93 of /application/modules/Video/Job/Encode.php:
      // Make sure FFMPEG can be run if( !@file_exists($ffmpeg_path) || !@is_executable($ffmpeg_path) ) { $output = null; $return = null; exec($ffmpeg_path . ' -version', $output, $return); if( $return > 0 ) { throw new Video_Model_Exception('Ffmpeg found, but is not executable'); } } ‚Äč
    6. What is the value of ffmpeg_path under Admin Panel > Plugins > Video > Global Settings