Forums » SEPHP Help and Tips

Landing Page Popular Blog Entries

    • 276 posts
    April 29, 2021 11:00 AM EDT

    Hei Folks.

    Seem to be having a problem with my 'Landing Page Popular Blog Entries' 

    Im using SE V5.5 with the Serenity theme.

     

    Not sure if the problem is the widget itself or a bug.

     

    I have tried altering blog settings and permissions in many ways but i cant get blogs to appear on Landing Page.

     

    Wondering if others have or had the same issue.

     

    Any ideas...

     

    thanks

    mikel.

    • Moderator
    • 5579 posts
    April 29, 2021 11:19 AM EDT

    https://demo.socialengine.com/ they are appearing on our demo. You may want to check the blog privacy settings and that guests can view blogs. Also check that you have available blogs. 

    • 276 posts
    April 30, 2021 1:44 PM EDT

     Hei Donna.

     

    Guests... I dont have a Guests Option in my privacy settings.

     

    All i have is:
    Everyone
    All Registered Members
    Friends and Networks
    Friends of Friends
    Friends Only
    just Me.

     

    I have checked all other privacy settings for all other modules / plugins , member levels settings and i dont see 'Guest Option' in any of them.

     

    Il have another look round, in case i missed something.

     

    Thanks Donna.

    • 276 posts
    April 30, 2021 2:03 PM EDT

    Hei Donna.

    Me again...mikel... Hello

     

    Ive had a look again and compared my site to the demo site and result is:

    All my settings match the settings on the demo. I have even proceeded to create a blog on demo to compare my site process to Demo process.

    I created the settings exactly the same on my site, yet i still do not see Blogs appearing on my sites Landing Page. I have been through my list of blogs to check privacy settings ( all set to 'Everyone') as there is no 'Guest Setting'

     

    MMmm, its a puzzler.

     

    Thanks
    mikel.

    • Moderator
    • 5579 posts
    May 1, 2021 5:10 AM EDT

    Hard to say without seeing the site. Are you using the same landing page? The serenity theme allows you to pick which landing page to use. 

    • 276 posts
    May 2, 2021 12:24 PM EDT

    Hei Donna.

    Hope you having a groovey weekend..

     

    Landing Page.. just using the standard Landing page on Serenity theme. Not using the Backup landing pages.

     

    I have tried with all theme options including the theme i made from a copy of the Blue theme.

    For some reason, i keep thinking it could be a fault with the widget itself ? 'landing page Popular Blog Entries'.  could that be a possibility ? but if it was, other members would mention it also...

    But saying that, ive downloaded V5.5 Blog, updated the V5.5 version 2 times, also ive not read or heard of any other member having a similar issue.

     

    Its not a problem, its not a problem for my site.

     

    Thanks Donna.

    Mikel

    • Moderator
    • 5579 posts
    May 3, 2021 10:06 AM EDT

    Please make sure you are using the same landing page as the demo if you want to see blog posts. https://demo.socialengine.com/admin/serenity/settings

    • 276 posts
    May 3, 2021 12:19 PM EDT

     Hei Donna.

     

    Yes.. I am using the same Landing page as the Demo and the settings are the same as the demo.

     

    Unless im not seeing a setting somewhere that can restrict none members from seeing blogs ?

     

    Thanks Donna

    Mikel.

    • Moderator
    • 5579 posts
    May 3, 2021 4:10 PM EDT

    The one in the blog for the Public member level controls if they can see it. Otherwise, perhaps there are no public blogs? Maybe they have privacy or network settings on them?

    • 276 posts
    May 4, 2021 11:41 AM EDT

    Hei Donna.

     

    All 'Member Level Settings' are set to 'Yes, allow viewing of blogs'.

    I have checked all the blogs settings and the 'privacy' is set to 'Everyone' and set to be viewed by all networks.

     

    Its a real puzzle this one isnt it ?

     

    Would it help if i reinstalled all v5.5 again... just to see if it may solve the issue ?

     

    Thanks

    mikel.

    • 276 posts
    May 4, 2021 11:52 AM EDT

     I see that another member ' Rivale' is using Serenity Theme and has the Blogs showing on their Landing Page.

    I just sent a message asking what settings have been set.

     

    Il see what the reply is and compare.

     

    mikel.

    • 276 posts
    May 4, 2021 12:20 PM EDT

    Just had reply from Rivale along with screenshots. My settings are set just like Rivals' settings.

     

    have to think about this issue, 

     

    mikel.

    • 276 posts
    May 6, 2021 11:26 AM EDT

    Hei Folks.

    This issue is now fixed.

    The reason i could not get Blogs to show on my Landing Page was the fact that All of the blogs were assigned to Networks. This prevents Blogs from showing to the Public.

    Donna had a look at my site and saw the error and corrected one of the  blogs that Donna created. Now i can see the Blog on my Landing Page.

     

    So for anyone with a similar issue as mine, Remember the solution is:
    If you want Blogs to show on the Landing Page, Do Not assign Blogs to Networks.

     

    Many Thanks to Donna for this Help and solution.

     

    Thanks Donna

     

    Mikel.

    • Moderator
    • 5579 posts
    May 7, 2021 4:58 AM EDT

    You're welcome!