Forums » SEPHP Help and Tips

Payment Plan duration not working correctly

    • 33 posts
    May 28, 2021 9:42 AM EDT

    Hello, I created a payment plan for 2 weeks:

     

    However all of the members who have subscribed to it seem to get 28 days. 

     

     

    Any help would be appreciated!

     

    Many thanks

     

    Ed Clarke 

    • Moderator
    • 5835 posts
    May 30, 2021 3:36 PM EDT

    This isn't a bug. You've not set it up correctly. Note that the Billing Duration has to coincide with the Billing Cycle. You can't use Weeks in the Billing Duration when there are no Weeks for the Billing Cycle. The Weeks setting, as shown in this tutorial, is for having a free trial for x weeks, https://socialengine.atlassian.net/wiki/spaces/SU/pages/5308799/SE+PHP+-+Setting+Up+Subscription+Plans . Please create a new plan with this in mind.

    • 33 posts
    June 1, 2021 12:03 PM EDT

    I am not following. It is a one time payment of £15 for 2 weeks membership. 

    There is no billing cycle. 

     

    • Moderator
    • 5835 posts
    June 1, 2021 1:56 PM EDT

    As I said, the weekly plan is ONLY for a free trial. It was never meant for the paid memberships. You can't do it that way. It has GOT to be a one time thing.

    • 33 posts
    June 2, 2021 1:52 AM EDT

    Ok, thanks for explaining that to me. So am I correct in thinking you can't have a 1 time payment for a single duration unless it is unlimited.

    I was confused as it still displays an expiry date (however the date was incorrect) 

    Many thanks

    Ed - Stay Safe 

    • 33 posts
    June 14, 2021 7:35 AM EDT

    I really think there is a problem with Social Engines Payment system. Does nobody else use a paid membership model. 

    Look at these subscriptions from active members. The expiry dates are way out.. 

    the monthly subscriptions expire in 3 months 

     

    The annual memberships expire in 3 years!

     

    My settings are correct in the plans. This is the monthly one:

    • Moderator
    • 5835 posts
    June 14, 2021 7:54 AM EDT

    We use it here and many other clients use it. I hadn't heard of any issues other than what you reported. But we can have a look.

    • Moderator
    • 5835 posts
    June 14, 2021 7:57 AM EDT

    I'll test on a staging as it's correct here but we use quarterly.

    • Moderator
    • 5835 posts
    June 14, 2021 8:08 AM EDT

    I'm not having any trouble with the payment plans. Are you sure there aren't some customizations to your site? Are you using 5.6?

    • 33 posts
    June 14, 2021 11:32 PM EDT

    Strange. I am using the latest version on SE. I don't have any customisations, only plugins from SES 

    • Moderator
    • 5835 posts
    June 15, 2021 5:13 AM EDT

    Plugins are customizations too in that they change the script. Can you check with them please? 

    • 33 posts
    June 15, 2021 10:26 PM EDT

    Hello Donna, I contacted SES and their reply was: We would like to inform you that it is not related to any of our plugin, member subscription is done through SE core module.

     

    Would it be possible to get your developer to look at it. I did pay for support before and didn't use it as it turned out to be a bug which was fixed on the SE update!

    I have created a ticket with all the details: Ticket Created #350865

    Many thanks

    • Moderator
    • 5835 posts
    June 16, 2021 5:17 AM EDT

    They are our developers. I sent them a note reminding them of that.

    • 33 posts
    June 18, 2021 6:57 AM EDT

    Thanks Donna, I will await a reply from them I guess. 

    Appreciate your help on this!

    • Moderator
    • 5835 posts
    June 18, 2021 7:01 AM EDT

    You're welcome. Please let me know if they don't answer and I'll get Shubhra to have a look.