Internal Server Error

    • 103 posts
    December 1, 2021 5:03 PM EST

    Hello,

     

    I've installed a new Social Engine at the url onepiece-rpg.fr, but there is an internal server error, and my hosting support that I should check if there is something wrong with the .htaccess below, can you help me with that :

    # $Id: .htaccess 9977 2013-03-19 20:51:56Z john $
    
    <IfModule mod_rewrite.c>
      Options +FollowSymLinks
      RewriteEngine On
    
      # Get rid of index.php
      RewriteCond %{REQUEST_URI} /index\.php
      RewriteRule (.*) index.php?rewrite=2 [L,QSA]
    
      # Rewrite all directory-looking urls
      RewriteCond %{REQUEST_URI} /$
      RewriteRule (.*) index.php?rewrite=1 [L,QSA]
    
      # Try to route missing files
      RewriteCond %{REQUEST_FILENAME} !-f
      RewriteCond %{REQUEST_FILENAME} public\/ [OR]
      RewriteCond %{REQUEST_FILENAME} \.(jpg|gif|png|ico|flv|htm|html|php|css|js)$
      RewriteRule . - [L]
    
      # If the file doesn't exist, rewrite to index
      RewriteCond %{REQUEST_FILENAME} !-f
      RewriteCond %{REQUEST_FILENAME} !-d
      RewriteRule ^(.*)$ index.php?rewrite=1 [L,QSA]
    
    </IfModule>
    
    # sends requests /index.php/path/to/module/ to "index.php"
    # AcceptPathInfo On
    
    # @todo This may not be effective in some cases
    FileETag Size
    
    <IfModule mod_deflate.c>
      AddOutputFilterByType DEFLATE text/text text/html text/plain text/xml text/css application/x-javascript application/javascript
    </IfModule>
    
    • Moderator
    • 6297 posts
    December 2, 2021 5:48 AM EST

    If you're still hosting with BryZar, I'm surprised they sent as they know SEPHP very, very well. 

     

    Here's a link to a tutorial with an htaccess in it. I suggest you compare yours with the original download or check this tutorial: https://socialengine.atlassian.net/wiki/spaces/SU/pages/5308752/SE+PHP+-+How+to+Protect+Your+Site+Using+SSL+and+HTTPS

     

    As htaccess does have to work on your server, your host would be best to know what works and what doesn't for your server configuration. 

    • 103 posts
    December 2, 2021 5:55 AM EST

    No I'm not hosted by Bryzar anymore, my hosting support told me that there were error logs as shown on the screenshot below.

    • Moderator
    • 6297 posts
    December 2, 2021 6:07 AM EST

    Well it looks like your host isn't set up properly. That is showing something regarding the symlinks and the server configuration. Let me post the requirements here and please have your host check them thoroughly, especially the notes:

     

    https://socialengine.atlassian.net/wiki/spaces/SU/pages/81788966/SE+PHP+-+SocialEngine+Requirements

     

    Then, I suggest you check your htaccess from the server with the download files you have for SEPHP from your account. Noting that htaccess also needs to configure per the server and some things may not work in some configurations. That's where the experience level of the host comes into play to help you solve an issue with what works and doesn't with your configuration.

     

    Here's more info on that server error, https://support.plesk.com/hc/en-us/articles/115001125289-A-website-hosted-in-Plesk-shows-500-Internal-Server-Error-Option-FollowSymLinks-not-allowed-here which shows what the host should have known to enable by reading that error.

    • 103 posts
    December 2, 2021 8:18 AM EST

    Thank you for the update, my hosting support was able to resolve the error. I succeeded to finalize the installation but I didn't see the page to choose my username and password so I cannot login. Can you help me with this problem too ?

    • Moderator
    • 6297 posts
    December 2, 2021 8:21 AM EST

    Then it most likely did not install correctly. Your host may not have followed the requirements. If they didn't, it can irreparably damage the site. Please ensure that you are not on shared hosting. Please have them check all of the requirements, especially the notes in the requirements as there are specific things in there that have to be set that way. Such as PHP cannot be above 7.2 . The database MUST be MySQL and not MariaDB. Other things as well are in the notes.

    • 103 posts
    December 2, 2021 8:27 AM EST

    Ok and after that everything will be checked so I should install Social Engine again ?

    • Moderator
    • 6297 posts
    December 2, 2021 8:28 AM EST

    Yes, if it didn't have you create a user, you should as there could be other things that didn't install fully.

    • 103 posts
    December 2, 2021 8:29 AM EST

    Ok thank you for the informations.

    • 103 posts
    December 2, 2021 8:55 AM EST

    I would like to know do I also have to reupload all the files on my server ?

    • Moderator
    • 6297 posts
    December 3, 2021 4:44 AM EST

    Sorry for the late response. Yes that would probably be better.