Plugins for v6.0

    • 14 posts
    April 27, 2022 6:49 PM EDT

    Do v5.9 Plugins work for v6.0?

    • Moderator
    • 6369 posts
    April 28, 2022 5:44 AM EDT

    No they tend not to. It's best to ask the third party expert who made your products though. We have a lot of big improvements in v6 that can make v5 plugins not work. 

    • Moderator
    • 6369 posts
    April 28, 2022 5:44 AM EDT

    I've moved this to the correct forum, 3rd party product discussions.

    • 257 posts
    August 29, 2022 4:14 AM EDT

    Indeed and we have been waiting for several months for our supplier to update our addons.

    The third-party developers should have been warned beforehand of such a change and of the mass of work that this would represent for certain.

    This would have been possible if a real consultation had been planned.

    So we have 6.0 licenses which are useless and there is no question of changing supplier for our addons.

    We have invested too much time and money.

    And we will not purchase any more license until these issues are resolved. It's the dog biting its own tail.

     

    • Moderator
    • 6369 posts
    August 29, 2022 5:13 AM EDT

    They were warned beforehand. 

    • 257 posts
    August 29, 2022 5:52 AM EDT

    So there must be a serious internal resource problem. In time, we will see... or not...

    • Moderator
    • 6369 posts
    August 29, 2022 5:58 AM EDT

    I think it's mainly due to the massive improvements in v6. Some experts have quite a lot of addons and it is taking them quite a lot longer to update all of them. Remember, we mentioned we upgraded zend via custom upgrade (massive improvement), removed mootools (major, major improvement) and this will be a big thing for plugins, added bootstrap (yay! bootstrap is awesome for themes), and fixed quite a lot of issues with PHP 8. These plugins also all need to update to PHP 8 as PHP 7.4 itself will soon be obsolete so many hosts will start updating to PHP 8. Even PHP 8.0 is becoming old and next year will not be supported by PHP, they will support 8.1 and up. https://www.php.net/supported-versions.php

    So, it's not just our upgrade, it's also PHP that they have to work with.