Forums » SEPHP Help and Tips

E-mails links are not clickable!

    • 57 posts
    October 26, 2017 1:19 PM EDT

    Hi, 

    I noticed that the links in the e-mails of my Social Engine network aren't clickable! And the same happens for the e-mails of this community! 

    Did you notice it too?

  • gs
    • 861 posts
    October 26, 2017 2:11 PM EDT

    Yes, but in my case it seems it's usually based on which email app I use.  Typically the links are not clickable in Thunderbird, yet they are in my webmail and my AquaMail Android app.

     

    2 years ago when I noticed this, I vaguely recall reading something about the way the email is formatted, but I may be remembering this incorrectly.  Anyway, since my experience showed it does work on some platforms, I just figured there's nothing that can be done because it's the email platform that is controlling it.

     

    Looking forward to input from others to see if this is resolvable or just the way life is due to different email platforms.

    • Moderator
    • 4263 posts
    October 27, 2017 4:34 AM EDT

    They are clickable for me in Gmail. I don't download emails to my computers any more so I've not tested with various mail programs. Thanks @gs for the details you gave. Perhaps those will help in troubleshooting. There may be some setting in the email program that sets links to clickable and most likely it would be in security settings. Email programs can disable links for security purposes to avoid phishing emails.

    • 57 posts
    October 27, 2017 6:59 AM EDT

    I exclude it is a client problem, because with the same client the e-mails of the original language pack are clickable, while those of the language pack translated no!

    • Moderator
    • 4263 posts
    October 27, 2017 7:47 AM EDT
    SE iBT said:

    I exclude it is a client problem, because with the same client the e-mails of the original language pack are clickable, while those of the language pack translated no!

    Always a good idea to give information like that when posting the original issue so that everyone helping has full details.

    Make sure they translated the email templates correctly:

    https://support.socialengine.com/php/customer/en/portal/articles/1639902-admin-panel---settings->-mail-templates?b_id=14386

    https://support.socialengine.com/php/customer/en/portal/articles/1648202-placeholders-in-email-templates-not-getting-replaced?b_id=14386

    • 5 posts
    October 28, 2017 5:31 AM EDT

    Hi all SE members,

    I think I could help you solving this. Normal mail for Lost password:

    [header]

    You have requested to reset your password because you have forgotten your password. If you did not request this, please ignore it. It will expire in 24 hours. To reset your password, please click the following link:

    http://[host][object_link]

    [footer]

     

    Improved mail for clickable link:

    [header]

    Same text as above example.

    http://[host][object_link]

    [footer]

    • 5 posts
    October 28, 2017 5:34 AM EDT

    Sry guys,

    Forum transformed and shorten my link. This is what I meant:

     

    • Moderator
    • 4263 posts
    October 28, 2017 6:20 AM EDT

     Thanks for the tips Tintin. Please remember our posting guidelines and use the code tags any time you want to post code. It's in the buttons and is the last button at the top of the editor, next to the smiley button. That will allow you to post code snippets without issues and they will be easy for people to copy/paste to use them.

    • 5 posts
    October 29, 2017 9:02 AM EDT

    Hi,

    And thank you for the tip Donna. I totally forgot about that button, it's in so many forums over the Internet.

    Here is the right code:

    <a href=""http://[host][object_link]"">http://[host][object_link]</a>
    • 57 posts
    October 30, 2017 3:35 AM EDT

    Tintin, I don't understand... could you explain me?

    • 5 posts
    November 6, 2017 8:33 AM EST

    Hi SE iBT and others,

    Been really busy this week, and I complicated the answer above. So here is a better explanation with more steps.

    You should replace the following code:

    http://[host][object_link]

     

    With this one:

    <a href=""http://[host][object_link]"">http://[host][object_link]</a>

     

    You should try that with one email template like Lost password. If it works change all email templates.

    Changing that code could be achieved in 2 ways:

    1.) Through Admin panel > Settings > Mail Templates. Find your template and change code.

    2.) Changing .csv files. For example download core.csv file, find Lost password section and the code. Change it with new one and upload to your server.

         This second step could be also made through Language Manager - if you aren't familiar with .csv files.

    • 57 posts
    November 17, 2017 4:28 AM EST

    Thank you so much Tintin!!! 

    • 57 posts
    December 13, 2017 4:00 AM EST

    Hi Tintin, 

    I tried your solution, the result was that the links are clickable, but if I click on it nothing happens!

    • 5 posts
    December 16, 2017 3:34 PM EST

    Hi SE iBT,

    Good to hear that links are clickable, I tested it with Yahoo mail some 3 years ago.

    But in my case it directed to the right page, don't know what is wrong with your setup.

    Perhaps Donna could help us with this.

    • Moderator
    • 4263 posts
    December 17, 2017 4:39 AM EST

    It's hard for me to help as all of the links from my own live site are clickable. I use gmail and open it in the browser. As mentioned above, it's due to the email app/software being used. Try opening in a different app or in browser.