Forums » 3rd Party Product Discussions

upgrade issue with 4.10

    • 38 posts
    February 17, 2018 8:28 AM EST
    Donna said:
    SpiritWolfie said:

    I agree with you Donna on this one, they had plenty of time for this specif update to get things in order, but honestly this issue seems like "two databases" trying to write to the same thing, so ether they need to create their own or figure out how to release it to 'Core/activity' package updates for database insert...

    It shouldn't be a hard issue to resolve on ethers persons end, and honestly having a fully flash removal from our websites is a amazing thing, (Cough looking at you SEAO for advance photo album still having flash!)

    Flash is dead peeps, GET RID OF IT FROM YOUR PLUGINS, it is also a MAJOR Security risk for all websites these days

    All and all, perhaps you should try contacting SEAO since its a major player in the SE game and ask them for free copies?

    but this info should also be plublished on how to fix these problems instead of having to beg/bash our heads agaist the walls, Common issues like this should have a HOW TO RESOLVE Doc somewhere.. because we keep running into them :(

    I am not sure how to resolve it as we didn't code their plugin but I'm trying to get a look in a default install, just a sec.


    Wasn't referring to you guys resolving it I was saying perhaps SE and SEAO should open up a dialog on this spefic issue, since it seems to be soo common and find out if theirs anything your team or their team can do to prevent it in the future.

    • Moderator
    • 5860 posts
    February 18, 2018 1:23 PM EST

    There are several clients with this issue. All of them are using third party plugins with a core and for the ones with both the core and activity database upgrade issue - all are using the advanced feeds. I've sent a message to two experts about this and asking them to update their plugins or to look into the issue as we cannot reproduce this issue on sites without third party "core" or "advanced walls" as of this time.

    • 38 posts
    February 18, 2018 6:46 PM EST

    Ya i'm still waiting to hear back from SEAO myself, I emailed their support and even facebook messaged them so far no luck, could be due to the fact its sunday.

    They also need to remove flash out of their plugins.

  • gs
    • 857 posts
    February 18, 2018 8:09 PM EST

    ==> '...When we say in our blog to not upgrade until you check with third parties, it is in order to not cause issues such as this...If experts did not have sufficient time to update, they had sufficient time to send notices to their clients not to upgrade until they get their stuff done...'

     

    This is similar to backups and testing in a Dev environment- all the warnings or notices in the world won't prevent someone from attempting to do something they were warned not to (I can tell my kids not to drive with the engine light on, write them notes, send them emails - but if they choose to do it anyway, there's not much more I can do to prevent it).  I have Plugins (only 1 certified) from 8 3PDs and none if them have 4.10 compatible versions yet - neither was I expecting them to this soon.  So in addition to waiting for 3PD upgrades to be available before jumping on a new SE version, something I've learned is to have the 3PD perform their own upgrades to the site (for somethg major like .09 and .10).  Last year it took over 2 months to get everything coordinated and upgraded and functional with 4.09 and PHP 7.* on my site, and that didn't start until after all Plugins/Theme were supposedly compatible with 4.09 (plus part of the delay was due to disabled Plugins not being disabled - which SE Support had to fix in their code).

     

    We've waited this long for 4.10, and thanks to the effort of everyone at SE it was released days ago.  Kudos to everyone at SE - including Spencer :)   So now we'll continue to be patient as 3PDs get caught up - this is the world of software, not life/death surgery.  SE is a grest CMS with great people working at SE, and I'm fortunate to be working with so many excellent people as 3PDs as well.  Grateful to all of you for last year's 4.09 and now 4.10.  Looking forward to FRs being addressed as this year progresses.  Keep up the great job!

     


    This post was edited by gs at February 18, 2018 8:21 PM EST
    • 38 posts
    February 18, 2018 11:41 PM EST

    GS

    The reality is as donna said these 3rd partie addons have had plenty of time to have their stuff prepped, They should have known how egered people would be to get off Flash, My entire website is focused around artwork and content creation, I've lost countless users because they just could not upload art etc... without having to do a ton of extra steps, because flash is hard blocked in almost every major browser and has been for a while...

    So having no flash SE is a must have!, flash has been dead for a LONG time, and is such a security risk that users wont even install it these days for security/safety concerns, those that do, still have uploading issues because it just doesn't work....


    their where a beta and RC client they could have gotten their stuff in order on, they've had countless months since it was announced to get their stuff in order, ontop of that, I myself have told SEAO to get off Flash etc... 

    So most of my site is updated to 4.10 except activity and core atm, which should be soonish to get updated.

    • Moderator
    • 5860 posts
    February 19, 2018 4:59 AM EST
    gs said:

    ==> '...When we say in our blog to not upgrade until you check with third parties, it is in order to not cause issues such as this...If experts did not have sufficient time to update, they had sufficient time to send notices to their clients not to upgrade until they get their stuff done...'

     

    This is similar to backups and testing in a Dev environment- all the warnings or notices in the world won't prevent someone from attempting to do something they were warned not to (I can tell my kids not to drive with the engine light on, write them notes, send them emails - but if they choose to do it anyway, there's not much more I can do to prevent it).  I have Plugins (only 1 certified) from 8 3PDs and none if them have 4.10 compatible versions yet - neither was I expecting them to this soon.  So in addition to waiting for 3PD upgrades to be available before jumping on a new SE version, something I've learned is to have the 3PD perform their own upgrades to the site (for somethg major like .09 and .10).  Last year it took over 2 months to get everything coordinated and upgraded and functional with 4.09 and PHP 7.* on my site, and that didn't start until after all Plugins/Theme were supposedly compatible with 4.09 (plus part of the delay was due to disabled Plugins not being disabled - which SE Support had to fix in their code).

     

    We've waited this long for 4.10, and thanks to the effort of everyone at SE it was released days ago.  Kudos to everyone at SE - including Spencer :)   So now we'll continue to be patient as 3PDs get caught up - this is the world of software, not life/death surgery.  SE is a grest CMS with great people working at SE, and I'm fortunate to be working with so many excellent people as 3PDs as well.  Grateful to all of you for last year's 4.09 and now 4.10.  Looking forward to FRs being addressed as this year progresses.  Keep up the great job!

     

    Thank you! cool

    • Moderator
    • 5860 posts
    February 19, 2018 5:03 AM EST
    SpiritWolfie said:

    GS

    The reality is as donna said these 3rd partie addons have had plenty of time to have their stuff prepped, They should have known how egered people would be to get off Flash, My entire website is focused around artwork and content creation, I've lost countless users because they just could not upload art etc... without having to do a ton of extra steps, because flash is hard blocked in almost every major browser and has been for a while...

    So having no flash SE is a must have!, flash has been dead for a LONG time, and is such a security risk that users wont even install it these days for security/safety concerns, those that do, still have uploading issues because it just doesn't work....


    their where a beta and RC client they could have gotten their stuff in order on, they've had countless months since it was announced to get their stuff in order, ontop of that, I myself have told SEAO to get off Flash etc... 

    So most of my site is updated to 4.10 except activity and core atm, which should be soonish to get updated.

    I'm also still waiting to see if our core devs can find a solution though tbh the main script should never have to work around issues like this. We'll have to look at some sort  of improvements in the future so that either clients know when a column is being added to a core db (core being part of se, not core meaning the core module), or so that it just doesn't allow it and devs find some other solution to do their things without altering it. 

    Good thing is, certified tests stuff and doesn't allow core (source) modifications. Also it has a deadline for updates. Doesn't help right now for this issue though as those products aren't certified.

    • Moderator
    • 5860 posts
    February 19, 2018 5:15 AM EST

    Ok. We aren't sure what we can do as that's our column now and experts need to conform. We may be able to make a patch that skips it during the upgrade so that you all can still upgrade and then have third parties update their products but we aren't sure if that will break other things. We don't have the SEAO or SES activity feeds or cores to check those columns. If someone wants to send me those, we can take a look. We need to check the code or install it to see. PM me if you want to do that. As we are the official company, it is not piracy to do this. We are authorized to receive third party files. 

    • 38 posts
    February 19, 2018 7:11 AM EST

    They are domain locked and lincs locked, so unless you subdomain it wont work, but i'd happily send you everything I have from SEAO

    SEAO isn't certified with you guys? they are one of thee major players in the plugin with social engine from what I see.

    • Moderator
    • 5860 posts
    February 19, 2018 7:14 AM EST

    The certified marketplace products. They haven't submitted these for certification. I've heard back from Amit at SEAO. They do have that column. I'm responding to him now. 

  • gs
    • 857 posts
    February 19, 2018 8:41 AM EST
    What's interesting is that if this truly is an issue with SES/SEAO products, then why didn't they notice this issue and inform SE weeks/months ago in order to work out a solution before 4.10 was released.
    • Moderator
    • 5860 posts
    February 19, 2018 9:25 AM EST
    gs said:
    What's interesting is that if this truly is an issue with SES/SEAO products, then why didn't they notice this issue and inform SE weeks/months ago in order to work out a solution before 4.10 was released.

    That is what I asked Amit at SEAO. I've asked them to make a fix quickly for this issue. 

    • Moderator
    • 5860 posts
    February 21, 2018 4:51 AM EST

    SocialEngineAddOns has fixed their issue. Please see their blog https://www.socialengineaddons.com/content/compatibility-plugins-socialengine-4-10

  • gs
    • 857 posts
    February 21, 2018 2:17 PM EST

    Kudos to SEAO for taking care of this so quickly (within about 3 business days after SE 4.10 was released).  Hope people that jumped the gun on upgrades  appreciate their efforts and have resolved their issues :)