Forums » 3rd Party Product Discussions

Admin Unable to view all Newsfeed Activity

    • 32 posts
    May 3, 2018 10:09 PM EDT

    We are currently running SE 4.10.3p1. As we understood, prior to 4.10 there was a bug that prevented admins from viewing all posts. It seems this is still not resolved. We discovered that post with a privacy setting of Friends & Network or higher are not viewable on the wall. Can someone confirm if was an issue and if it has been resolved?

    • Moderator
    • 5860 posts
    May 4, 2018 5:04 AM EDT

    Have you checked the super admin member level settings? Can you give more details about how to reproduce this? 

    • Moderator
    • 5860 posts
    May 4, 2018 6:29 AM EDT

    I've tested the following way, with super admin user:

    1. Logged in one browser as super admin.

    2. Logged in another browser with a user who is not friends with super admin and who is in a network that super admin does not belong to.

    3. I posted in the main activity feed:

    • admin stinks (Friends and Network privacy)
      • super admin user can see this one
    • admin really stinks (north american network privacy that super admin is not a member of)
      • super admin can see this
    • admin is a stinker (friends only privacy)
      • super admin can see this

    The feed settings are set to All Members in the admin panel settings.

    • 32 posts
    May 4, 2018 3:20 PM EDT

    Unfortunately this is not how our activity feed is behaving. We are using the Advanced Activity feed by SEAO. I will reach out to them to ensure this is not an issue on their end.

     

    Thanks Donna

    • Moderator
    • 5860 posts
    May 4, 2018 5:29 PM EDT

    Ok perhaps it is the plugin. I would say to disable and test but it overwrites source code so any testing wouldn't be true unless you did it on an unmodified development site.

  • gs
    • 857 posts
    May 4, 2018 6:00 PM EDT

    ==> '...I would say to disable and test but it overwrites source code so any testing wouldn't be true unless you did it on an unmodified development site....'

    I didn't realize this - I thought the recent issues with v10.* Adv Activity Plugins by SES and SEAO were database core changes, not code.  Is core code overwiting without informing clients something new with their v10.* Plugins?  My hope was that the Disable would still work properly.  Has anyone actually tried this with these SES/SEAO Plugins, or heard from them if this is the case that Disable does not work?

    • Moderator
    • 5860 posts
    May 4, 2018 6:16 PM EDT
    gs said:

    ==> '...I would say to disable and test but it overwrites source code so any testing wouldn't be true unless you did it on an unmodified development site....'

    I didn't realize this - I thought the recent issues with v10.* Adv Activity Plugins by SES and SEAO were database core changes, not code.  Is core code overwiting without informing clients something new with their v10.* Plugins?  My hope was that the Disable would still work properly.  Has anyone actually tried this with these SES/SEAO Plugins, or heard from them if this is the case that Disable does not work?

    I had been told that they modify source code in order to do some feed things. Perhaps I am mistaken. Easy way to find out is check the code. 

    • 32 posts
    May 6, 2018 9:31 PM EDT

    Well...in an attempt to diagnose the issue we created a clone of the "Member Home Page" in pages, and swapped out the "Advanced Activity Feed" with the SE core "Activity Feed". We were able to see the images. This confirms that this is in fact an issue the the SEAO Advance Activity Feed Plugin. Anyone who is running this plugin should perform this same test to ensure they are seeing all the posts.

    On a side note, I looked at the code and files for the "Advanced Activity Feed" issued by SEAO. They do replace one code file, /application/libraries/Engine/Loader.php. However, the files are the exact same with no edits. Not sure why they did this.


    This post was edited by CNDAdmin at May 6, 2018 11:15 PM EDT
  • gs
    • 857 posts
    May 6, 2018 11:02 PM EDT

    @CNDAdmin

    Thx for taking the time to test, and for posting the results.

    • 32 posts
    May 8, 2018 12:36 AM EDT

    I discussed the replacing of the core file with SEAO this evening and I wanted to follow up with the information they provided. It seem this file, /application/libraries/Engine/Loader.php, is a file that is in the core list of files for version 4.10.3. However, it wasn't included in some previous versions of SE. They include this file in their plugin to allow people on a previous version of SE that didn't include this file to option of not upgrading to a later version of SE and still be able to use the script. This would explain why the file included in the Advanced Activity Feed is exactly the same as the core file. So they are simply including a core file found in the latest versions of SE with their plugin. Not replacing it.

    • Moderator
    • 5860 posts
    May 8, 2018 5:03 AM EDT
    CNDAdmin said:

     So they are simply including a core file found in the latest versions of SE with their plugin. Not replacing it.

    We don't allow sharing of our files. This would be against our licensing and our copyright. We will take this up with SEAO.