Forums » SEPHP Help and Tips

Continue Social Engine 4 Version Numbers

    • 626 posts
    July 17, 2017 12:10 PM EDT

    I'm not sure if developers are ready for a change in how social engine directly accesses existing files based on the relationship between the core and third party solutions.

    If social engine 4 is required, making a direct change in the near future to social engine 5 may reduce the number of compatible plugins to social engine.

    • Moderator
    • 5937 posts
    July 18, 2017 6:22 AM EDT

    Please read our stickied guidelines for posting feature requests. Please update this with full details.I'm not sure what you are asking for with this request.

    • 626 posts
    July 23, 2017 2:05 AM EDT
    Donna said:

    Please read our stickied guidelines for posting feature requests. Please update this with full details.I'm not sure what you are asking for with this request.

     

    I thought this was self explanatory but here goes.

    (Thanks for reporting an issue! Please make sure you click the link above to view the issue guidelines, then fill out the blanks below.)
    What are the steps to reproduce this issue?
    1. … Assume social engine reaches version 5.x number system.
    2. … Assume social engine code requires version 4.x for any modules to be compatible until the third parties such modules belong to are updated.
    3. … Assume the decision is considered to force plugin developers to upgrade compatibility requirements due to a proposed major coding update.
    What happens?
    … Assume clients are forced to buy a whole new license due to the major version change. Would this effect coding changes we make now through version 4.x or are they pretty much irrelevant?
    What were you expecting to happen?
    … Version numbers to remain the same unless a major coding change happens forcing the update to version 5. As in, getting rid of Zend to switch to volt or Twig. Otherwise leave version numbers 4.x compatible with third party modules. In other words, don't let version 4.10 become version 5.0 unless such a drastic incompatible coding change happens.
    Any logs, error output, etc?
    (If it’s long, please paste to https://ghostbin.com/ and insert the link here.)
    Paste Log Here
    Any other comments?
    … No log. Social Engine will at some point need to have less coding dependencies so that html output requires more content to characters ratio for better and faster page loading. Too many scripts load as it is on a per page basis, so improving the cms aspect of this would help.
    What versions of software are you using?
    Operating System: … Cloud Linux Offered By Name Cheap Shared Hosting - php7.1 Most Extensions Enabled accept Source Guardian see https://www.namecheap.com/support/knowledgebase/article.aspx/9697/2219/php-modules-and-extensions-on-shared-hosting-servers for details
    SocialEngine PHP Version: … 4.9.2p1 with all up to date plugins latest oldest version being 4.9.1