Forums » 3rd Party Product Discussions

Error Creating Product in Site Store Plugin

    • 4 posts
    September 18, 2018 3:00 AM EDT

    Hi There, when creating a product in a store, we are having the following issue. Having seen similar issue for gateways, we have enabled PayPal gateway but still not much help. Has anyone else had this problem??

    We are 4.10

    Zend_Json_Exception: Decoding failed: Syntax error in /var/www/html/application/libraries/Zend/Json.php:97

    Zend_Json_Exception: Decoding failed: Syntax error in /var/www/html/yyyyyyyy/application/libraries/Zend/Json.php:97
    Stack trace:
    #0 /var/www/html/yyyyyyyy/application/modules/Authorization/Model/DbTable/Permissions.php(88): Zend_Json::decode('')
    #1 /var/www/html/yyyyyyyy/application/modules/Sitestoreproduct/Form/Create.php(1176): Authorization_Model_DbTable_Permissions->getAllowed('sitestoreproduc...', Object(User_Model_User), 'auth_photo')
    #2 /var/www/html/yyyyyyyy/application/libraries/Zend/Form.php(239): Sitestoreproduct_Form_Create->init()
    #3 /var/www/html/yyyyyyyy/application/libraries/Engine/Form.php(146): Zend_Form->__construct(Array)
    #4 /var/www/html/yyyyyyyy/application/modules/Sitestoreproduct/controllers/IndexController.php(957): Engine_Form->__construct(Array)
    #5 /var/www/html/yyyyyyyy/application/libraries/Zend/Controller/Action.php(516): Sitestoreproduct_IndexController->createAction()
    #6 /var/www/html/yyyyyyyy/application/libraries/Zend/Controller/Dispatcher/Standard.php(308): Zend_Controller_Action->dispatch('createAction')
    #7 /var/www/html/yyyyyyyy/application/libraries/Zend/Controller/Front.php(954): Zend_Controller_Dispatcher_Standard->dispatch(Object(Zend_Controller_Request_Http), Object(Zend_Controller_Response_Http))
    #8 /var/www/html/yyyyyyyy/application/modules/Core/Bootstrap.php(84): Zend_Controller_Front->dispatch()
    #9 /var/www/html/yyyyyyyy/application/libraries/Engine/Application.php(160): Core_Bootstrap->run()
    #10 /var/www/html/yyyyyyyy/application/index.php(223): Engine_Application->run()
    #11 /var/www/html/yyyyyyyy/boot.php(47): include('/var/www/html/s...')
    #12 /var/www/html/yyyyyyyy/index.php(24): Engine_Boot->boot()
    #13 {main}

    Any help is appreciated.


    This post was edited by TEKXILA at September 18, 2018 3:02 AM EDT
    • 4 posts
    September 18, 2018 3:21 AM EDT

    Hi There,

    Just an update on it, I tried importing some products using Store -> Import functionality and noticed it works though.

    Reckon, there must be something with Creating product using the store functionality.

    Cheers

    • Moderator
    • 5871 posts
    September 18, 2018 4:49 AM EDT

    Moved to third party product discussions. Please contact the expert who made that plugin.

    • 4 posts
    September 18, 2018 5:54 AM EDT

    Thank you, @Donna