Community

Forums » SEPHP Help and Tips

Emails sent to Gmail Accounts Unauthenticated

  • Jo
    • 10 posts
    April 6, 2019 11:41 AM EDT

    Hi, 
    I have an issue, all emails sent from my community, that are sent to a gmail account they always have a question mark next to my email.

    I've asked my host provider to:
    Authenticate my email address 
    and they've helped me verify ownership of my website
    through TXT to the DNS configuration for Google to verify that I own it.

    But nothing has worked. Emails are still be sent to gmail accounts with a question mark.

    My host is unsure where the issue is either.

    I've attached a picture of what the email looks like with the question mark and the message that appears when I click the question mark.

     

    PS: I even tried changing the email address. But It's the same issue.

     

     

     

    • 3422 posts
    April 8, 2019 7:37 AM EDT

    I'm not sure what's up with this as we don't have the issue here and I don't have it at my own SEPHP site. We use Sendgrid for transactional mail which has better deliverability. We don't recommend using server mail unless it's a separate server such as BryZar has. If using your main server for mail, you would want to think about changing from that to a transactional mail service. It's safer in case you get any spam reports as most hosts will suspend a server for spam (even false reports). If using transactional mail, you don't risk that and also since they are so well known, the mail gets delivered better as the source is a verified source.

    Double check SPF and DKIM records should you choose to keep using server mail. Here's a blog from Sparkpost which I used to use for transactional mail, https://www.sparkpost.com/blog/understanding-spf-and-dkim/