Forums » SEPHP Help and Tips

Upgrade impossible, permissions denied!

    • 4 posts
    August 3, 2020 5:47 PM EDT

    I want to install the groups plugin on my site. Upon uploading I received a message that I needed to upgrade module_core to  4.10.5 (my current version is 4.10.2).

     

    So I uploaded the socialengine-php-upgrade, which includes module_core, and rather than installing I get a long list of Permission issues found:

     

    These include numerous instances of application is not writable, externals is not writable, plus boot.php is not writable, index.php is not writable, etc.

     

    In the past I've never had any problems upgrading. I did a search in these forums and did find reference to this, but the pages linked to have been removed.

     

    Eventually I'll want to upgrade to V5, but I sure don't want to invest and then not be able to install! I'd be grateful for any ideas...

     

    Thank you!

    • Moderator
    • 5237 posts
    August 4, 2020 5:08 AM EDT

    Please check requirements to make sure your host is not above the PHP requirements of 7.2. That can cause weird permission issues.

    Please check permissions to match the ones in the permission article at our Learning Center which is a great tool for finding documentation.

    • 4 posts
    August 4, 2020 11:51 AM EDT

    Thank you Donna!

     

    I see the permissions in the article (https://www.socialengine.com/support/article/5112151/se-php-optimized-file-and-folder-permissions) ... but before resetting permissions I have a question: There's no date on the article. I installed socialengine php in 2018 (reinstalled; I've been working with socialengine since 2008). To install a package/plugin, upgrading from 4.10.2 to 4.10.5 would permissions have changed?

     

    And it seems rather worrying that one might have to run an older version of php. My host/server is running 7.3 something now and everything is fine.

    • Moderator
    • 5237 posts
    August 4, 2020 11:55 AM EDT

    SEPHP does not support PHP 7.3 yet. It can cause random issues such as you are experiencing. We are working on v6 which will support 7.3 and up. Even v5 does not support 7.3 yet.

     

    Permissions can change as servers get updated so it's best to check those. Since you are having issues, it can be the perms or the version you are using. Also make sure you aren't using mariadb as that isn't supported.

     

    Hope those tips help. :)