Video Upload Problem

    • 12 posts
    December 2, 2022 1:31 PM EST

    I have 6.2.2 installed with the Video Plugin. 

    My users have no problem uploading small videos, they work just fine.

    But I am trying to upload a larger video, which is around 500MB in size.

    The upload starts but after some time, it errors out with the white error page.

    If I Look in the logs this is the error:

    2022-12-02T18:24:49+00:00 ERR (3): Error Code: a20cd9
    Error: Call to a member function setFromArray() on null in /home/domain/
    Stack trace:
    #0 /home/domain/ Video_IndexController->createAction()
    #1 /home/domain/ Zend_Controller_Action->dispatch('createAction')
    #2 /home/domain/ Zend_Controller_Dispatcher_Standard->dispatch(Object(Zend_Controller_Request_Http), Object(Zend_Controller_Response_Http))
    #3 /home/domain/ Zend_Controller_Front->dispatch()
    #4 /home/domain/ Core_Bootstrap->run()
    #5 /home/domain/ Engine_Application->run()
    #6 /home/domain/ include('/home/domain/s...')
    #7 /home/domain/ Engine_Boot->boot()
    #8 {main}


    In my php info (which is PHP 8.0) I have max upload size set to 1000M

    upload_max_filesize 1000M
    max_input_time -1

    Anyone have any idea what could be causing the file to not upload properly?

    Thank you!



    • Moderator
    • 6923 posts
    December 5, 2022 7:49 AM EST

    Your host will have to make adjustments. Try the post_max_size.

    • 12 posts
    December 5, 2022 8:01 AM EST

    Sadly, I have that changed to 1000M also. Here is a section of my php info

    log_errors	On	
    log_errors_max_len	1024	
    mail.add_x_header	On	
    mail.force_extra_parameters	no value	
    mail.log	no value	
    max_execution_time	120	
    max_file_uploads	20	
    max_input_nesting_level	64	
    max_input_time	-1	
    max_input_vars	1000	
    memory_limit	3000M	
    open_basedir	no value	
    output_buffering	0	
    output_encoding	no value	
    output_handler	no value	
    post_max_size	1000M	
    precision	14	
    • Moderator
    • 6923 posts
    December 8, 2022 5:31 AM EST

    Do you have cloudflare? It has its own restrictions and large files generally can fail if on the free cloudflare. If you don't have cloudflare, can your host help you? We have tested on our end just to make sure it's not a bug and we aren't having issues with large videos. We also have clients uploading large files and they aren't having this issue. This makes us think it's a site/server issue. If your host can't help resolve this for you, you could wait for a client to hopefully help (server issues aren't my wheelhouse), or you could check at SocialNetworking.Solutions in their support as they do offer support for issues like this. 

    • 266 posts
    March 10, 2023 3:48 AM EST

    I have been expereincing similar random errors. I think there is a problem with 6.x video processing and compatibility with PHP 8.0. I believe an "@" needs to be added before one of the arrays used in index.php to make it compatible with PHP8. I will file a proper bug report when I have more information.

    • 266 posts
    March 10, 2023 3:50 AM EST

    LexFrost, if you're reading this, does you /temporary/video/ folder contain a lot of xxx_vconverted.mp4 files? Or any? (It should have 0 once they are uploaded). If so, you are experiencing the same problem I am and it's not the processing of the videos, but SocialEngine not picking up when they are processed because it is bugging out due to not being compatible with PHP8, if my theory is correct.

    • 266 posts
    March 10, 2023 4:04 AM EST

    @LexFrost, also, in your Admin Panel > Settings > Task Scheduler > Job Queue, are there any messages next to the videos that fail to process? For me, I get the error "2 Undefined array key "m" /application/index.php 182".


    Further to the post I just made, there are '@' in front of $GET, but I think there is something else that needs to be done to make it compatible with PHP8.

    • Moderator
    • 6923 posts
    March 10, 2023 5:09 AM EST

    @Abuk, Does it have to be a huge video to test? I can test on my staging but only small videos.

    • 266 posts
    March 10, 2023 5:53 AM EST

    @Donna I am still working on it at present. I will probably file a more detailed bug report in the next six - 48hours with further info. (I want the original users who uploaded their videos to re-upload them before I confirm my solution works).


    The bug may also be the reason that temporary files are not being deleted when they should be, as it seems that any job run through the task scheduler that takes more than one cycle to complete is being shown an error and not being processed since moving to PHP8.

    • Moderator
    • 6923 posts
    March 10, 2023 5:58 AM EST

    Thank you Abuk. I'll test on my staging too. We are testing PHP 8.2 on that one.

    • 266 posts
    March 10, 2023 6:02 AM EST

    I have just checked, and the video files on my server range from 1.6MB to 178MB after conversion, I do not know what size they were when the users uploaded them. I think the key issue is do they take longer than one Task Scheduler cycle to process, and if so, they do not process.

    • Moderator
    • 6923 posts
    March 10, 2023 6:04 AM EST

    I see the same error in the task manager for a small video. I am going to bug this but will also update any bug report with anything extra you may add.

    • Moderator
    • 6923 posts
    March 10, 2023 6:06 AM EST

    But I am not getting the error for this thread. I am getting the error you mention Abuk but not the other error that started this thread. I think it could be two different issues. Are you seeing the same error that was posted in the first post?

    • 266 posts
    March 10, 2023 6:11 AM EST
    [url=/profile/donnab]Donna[/url] said: I see the same error in the task manager for a small video. I am going to bug this but will also update any bug report with anything extra you may add. OK. Some videos do work though, which is what makes this harder. For Donna only, DO NOT USE THIS CODE IF YOU ARE NOT DONNA: Edit /application/index.php, around lines 180-190, replace the //subapps code with this:
    // Sub apps
    if (!defined('_ENGINE_R_MAIN') && !defined('_ENGINE_R_INIT')) {
    if (isset($_GET['m'])){
        if (@$_GET['m'] == 'css') {
            define('_ENGINE_R_MAIN', 'css.php');
            define('_ENGINE_R_INIT', false);
        } elseif (@$_GET['m'] == 'lite') {
            define('_ENGINE_R_MAIN', 'lite.php');
            define('_ENGINE_R_INIT', true);
    else {
            define('_ENGINE_R_MAIN', false);
            define('_ENGINE_R_INIT', true);
    • 266 posts
    March 10, 2023 6:15 AM EST

     With regards to 'Am I seeing the same error as in the first post', I have now checked the logs and it is NOT the same error.


    I last experienced that error in December, so it looks like 6.3 sorted that error out.

    • Moderator
    • 6923 posts
    March 10, 2023 6:24 AM EST

    I hate to ask this but could we move this to a new bug report? I will test the above that you posted.

    • 266 posts
    March 10, 2023 6:28 AM EST

    @Donna I will. I only added to this discussion as I saw 'array' and thought it would be connected to my issue. A bug report will be forthcoming when I have more information from the original users.

    • Moderator
    • 6923 posts
    March 10, 2023 6:36 AM EST

    With your code, so far no issues seen. I will test more on Monday or later todaytea is a necessity in the morning lol.

    • Moderator
    • 6923 posts
    March 10, 2023 6:39 AM EST

    Thank you for your help