Disable Redis in phpMyAdmin

    • 13 posts
    January 10, 2023 6:59 AM EST

    Hey guys,

    I enabled Redis in the admin and now I seem to get a HTTP 500 respons, is there a way to disable Redis in phpMyAdmin?

     

    I can only find these service providers

    Engine_ServiceLocator_Plugin_Cache_File
    Engine_ServiceLocator_Plugin_Cache_Apc
    Engine_ServiceLocator_Plugin_Cache_Memcached

     

    Error I'm getting:

     

    Fatal error: Uncaught Error: Class "Engine_Cache_Backend_Redis" not found in /var/www/vhosts/unlisted.com/httpdocs/application/libraries/Zend/Cache.php:153 Stack trace: #0 /var/www/vhosts/unlisted.com/httpdocs/application/libraries/Zend/Cache.php(94): Zend_Cache::_makeBackend() #1 /var/www/vhosts/unlisted.com/httpdocs/application/libraries/Engine/Cache.php(211): Zend_Cache::factory() #2 /var/www/vhosts/unlisted.com/httpdocs/application/modules/Core/Bootstrap.php(287): Engine_Cache::factory() #3 /var/www/vhosts/unlisted.com/httpdocs/application/libraries/Engine/Application/Bootstrap/Abstract.php(256): Core_Bootstrap->_initCache() #4 /var/www/vhosts/unlisted.com/httpdocs/application/libraries/Engine/Application/Bootstrap/Abstract.php(207): Engine_Application_Bootstrap_Abstract->_executeResource() #5 /var/www/vhosts/unlisted.com/httpdocs/application/libraries/Engine/Application/Bootstrap/Abstract.php(150): Engine_Application_Bootstrap_Abstract->_bootstrap() #6 /var/www/vhosts/unlisted.com/httpdocs/application/libraries/Engine/Application.php(149): Engine_Application_Bootstrap_Abstract->bootstrap() #7 /var/www/vhosts/unlisted.com/httpdocs/application/index.php(235): Engine_Application->bootstrap() #8 /var/www/vhosts/unlisted.com/httpdocs/boot.php(47): include('...') #9 /var/www/vhosts/unlisted.com/httpdocs/index.php(24): Engine_Boot->boot() #10 {main} thrown in /var/www/vhosts/unlisted.com/httpdocs/application/libraries/Zend/Cache.php on line 153

    This post was edited by Donna at January 10, 2023 7:46 AM EST
    • Moderator
    • 6558 posts
    January 10, 2023 7:48 AM EST

    You change it in the cache.php file. https://community.socialengine.com/blogs/597/122/moving-your-website-to-another-server there are details in that post for how to work with the cache.php file.

    • 13 posts
    January 10, 2023 8:57 AM EST

    Hi Donna, that fixed the trick, thanks allot 

    • Moderator
    • 6558 posts
    January 10, 2023 9:08 AM EST

    Glad it worked! You're welcome.