Forums » SEPHP Help and Tips

Php7.1 and APCU

    • 1 posts
    November 29, 2017 8:34 AM EST

    socialengine said that the recommended php version is 7.1 with APCU installed for better performance. I asked my hosting to upgrade php 7.1 but said APCu is not available in PHP versions higher than 5.5. OPcache is the successor to the APC, and OPcache is only opcode cache. 

    also upon upgrade of my hosting socialengine is now hitting the runtime errors  under the PHP 7.1.

    my question is it true that APCu is not supported on php7.1? then why that it is recommended by socialengine to have php7.1 and apcu installed? what is the recommended caching configuration for php7.1? also what could be the problem of the site now it has runtime errors under php7.1? I got no error on php5.6.

     

    Hope to get a reply. TThanks in advance!

     

     

     

    • Moderator
    • 4260 posts
    November 29, 2017 10:35 AM EST

    I think you should try tmd or cazaratech (where I host). http://php.net/manual/en/intro.apcu.php APCu is available on php7. I use it on Mamp in 7.1.

    https://serverpilot.io/community/articles/how-to-install-the-php-apcu-extension.html just one in the google search for reference.

    • 23 posts
    November 29, 2017 4:56 PM EST

    opcache+apcu is a must.

    I recommend upcloud. I can set up everything for you if you want. They're ultrafast


    This post was edited by Donna at November 30, 2017 5:20 AM EST