Forums » SEPHP Help and Tips

SSL certificate not working

    • 8 posts
    December 21, 2017 2:22 PM EST

    Ok i have installed an SSL certificate on my site and it isnt working.

    Im on the latest version of SE.

    I have manually used my site with https and it says secure on some pages and some it doesnt. I understand the reason for that. I know I need to force https in my htaccess. My host says its all installed correctly. Ive also checked the SSL with SSL check tool.

    I have followed the instructions here in SE support

    SSL INSTRUCTIONS

    Once I do that I get this error on my site

    Internal Server Error

    The server encountered an internal error or misconfiguration and was unable to complete your request.

     

    Additionally, a 500 Internal Server Error error was encountered while trying to use an ErrorDocument to handle the request.

     

    I remove the code and get the SAME error.

    Its only when I delete the htaccess and restore the original one will the site resolve.

    Does anyone have SSL on their site who can let me know what worked for them?

    THANKS

    • Moderator
    • 4210 posts
    December 21, 2017 2:35 PM EST

    As you can see, we use ssl here. I use ssl on my author site. No issues. I'm using Let's encrypt. I followed the tutorial to get it set up. I believe I had to do something at Cloudflare but I may be wrong. 

    • 8 posts
    December 21, 2017 2:46 PM EST

    Yes i understand it works. Ive already paid for the SSL, its been installed. I need to know why its not working. This site is not on cloudflare for now. =)


    This post was edited by Max99 at December 21, 2017 2:46 PM EST
    • Moderator
    • 4210 posts
    December 21, 2017 8:32 PM EST

    It's hard to say with so few details. Check error logs and server error logs. See what shows up

    • 8 posts
    December 21, 2017 9:20 PM EST

    ok so it should work, lol. Im clueless...

    • Moderator
    • 4210 posts
    December 22, 2017 12:48 PM EST

    We are too without some info please. Check the error logs, check the server logs, have the host check the certificate, double check the htaccess.

    • Moderator
    • 4210 posts
    December 23, 2017 4:27 AM EST

    You could try an experiment. Try using Cloudflare's free ssl and then follow the ssl tutorial again, step by step. If it works, go back to your host and have them set up your ssl again. If it doesn't work, then more troubleshooting needs to be done.

    • 8 posts
    December 26, 2017 2:33 PM EST

    ha ha I just messaged you that I fixed it through cloudflare, thanks