Forums » SEPHP Help and Tips

Profile Questions ghosting in Profile

    • 95 posts
    March 13, 2018 11:50 AM EDT

    I have been working on my profiles and in doing so have made changes and deleted options as I went and learned the flow of the area within the admin section.

    I am now seeing some ghost options in both Signup and in Edit Profile (not in regular view profile). In the attached screenshot you can see the headings without a selection option. Those shouldn't show and the live proper versions show when you select a gender and are working.

    Any idea as to why? And I found the appropriate table in the DB with the options, is there a way to identify these ones and not the live versions?

    • 1446 posts
    March 14, 2018 5:08 AM EDT

    We had an issue in 4.10.0 and below that we fixed in 4.10.1 (I believe that's the fixed version). However, it didn't delete the duplicates. They should be in the profile questions to delete. If not, then it would be a matter of investigating to answer the good ones and look in the db for the ones without answers and delete those. I think they should have numbers in admin but I'll go look.

    • 1446 posts
    March 14, 2018 5:12 AM EDT

    I don't see any way to find the number in admin. 

    • 95 posts
    March 14, 2018 9:51 AM EDT

    ok good to know - I will dig around as its a dev site anyway and I can learn more about the area that way. 

    • 95 posts
    March 14, 2018 2:24 PM EDT

    I ended up deleting the Profile Type and started fresh. This removed the erroneous headings

    • 1446 posts
    March 15, 2018 5:11 AM EDT

    We'll have to improve this process in the future. Though it shouldn't have the duplicate types any more.

    • 95 posts
    March 15, 2018 12:47 PM EDT

    WIth more digging I found the following...

    I have 4 gender types and each are similar for profile questions. When I filled out the gender specific questions in one of the genders I forgot to fill out the variables for a few of the selections. These empty questions would then show up as above and disappeared once I filled in the variables.

    • 1446 posts
    March 16, 2018 4:49 AM EDT

    Weird. I don't think it'll do that now with that fix but I could be wrong.

    • 95 posts
    March 16, 2018 9:58 AM EDT

    This was on 4.10.1 

    • 1446 posts
    March 16, 2018 11:10 AM EDT

    I'll have to test more. So, it would duplicate the profile questions from another one? Or, it showed the fake profile questions from when you were testing? I know the fake ones would not have deleted due to the other bug before. Yeah, I know, it sounds like an Abbott and Costello "Who's on First" scenario. 

    This post was edited by Donna at March 16, 2018 11:10 AM EDT
    • 95 posts
    March 16, 2018 12:10 PM EDT

    LOL what's on second???

    Alright - I just redid what I was seeing to be clear - to reproduce do the following:

    1. Create more than 1 genders

    2. Create gender specific questions

    3. Leave a gender specific question blank for options (so the question is there but no answers to choose from with a select field such as radio buttons)

    with the above the blank an unselectable question will appear in the registration form and edit profile page as seen below with Test Q

    I am running Ver 4.10.2

    This post was edited by ITLJames at March 16, 2018 12:12 PM EDT