SocialEngine 6.4.3 and MariaDB

    • 265 posts
    July 21, 2023 7:38 AM EDT

    I have looked at the current SocialEngine requirements page, and am seeking clarification on what version(s) of MariaDB SocialEngine is compatible with.

     

    Historically, (prior to 6.2.2), SocialEngine was only compatible with MySQL and the version was listed as being minimum 5.7 and recommended 5.7. I have been using MySQL 8.0 since that time without issues until the 6.3 upgrade.

     

    At the moment, MariaDB 10.6 is listed as the recommended version, but there is no minimum or maximum version. Does SocialEngine work on 10.11, and is there  a minimum version it requires?

    • Moderator
    • 6923 posts
    July 24, 2023 5:21 AM EDT

    The only version tested was 10.6 so I am asking our team.

    • Moderator
    • 6923 posts
    July 24, 2023 8:00 AM EDT

    Right now, we have only tested in 10.6. So for now that is what we recommend.

    • 265 posts
    July 24, 2023 4:34 PM EDT

    Thanks Donna.

    • 303 posts
    July 26, 2023 6:18 AM EDT

    This is good news.

    • 318 posts
    September 4, 2023 4:50 AM EDT

     Sorry...

    Thank you for the message.

    Can we continue to use Mysql?

    Because initially, we were on MariaDb and we had to change...

    Do we absolutely have to go back to MariaDb?

    Thank you in advance

    • Moderator
    • 6923 posts
    September 4, 2023 5:23 AM EDT

    I use MySQL. We only added MariaDB to our list because many hosts these days use it. However, I prefer to use MySQL and our former CTO didn't recommend adding support for MariaDB as it's only a fork of MySQL and it's best to be on the main branch. You can use either.

    • 318 posts
    September 4, 2023 5:29 AM EDT

    Thanks a lot Donna...

    • Moderator
    • 6923 posts
    September 4, 2023 5:30 AM EDT

    You're welcomeHope it helps